1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sharp or Phillips?

Discussion in 'Plasma TVs' started by Agent 86, Sep 19, 2004.

  1. Agent 86

    Agent 86
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Disregarding price, what is the perceived wisdom as to which lcd tv model is better: the sharp lc-32g1e or the Philips 32" 9986? For example, I don't know what sort of picture processing goes on inside the separate av box in the sharp compared to pixel plus in the Philips.

    Regards,
    Tim
     
  2. ianh64

    ianh64
    Active Member

    Joined:
    Aug 7, 2004
    Messages:
    2,233
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    SW London/Surrey borders
    Ratings:
    +63
    Neither. IMHO The Loewe Xelos SL or as you said, disregarding price, the Loewe Spheros.
     
  3. ianh64

    ianh64
    Active Member

    Joined:
    Aug 7, 2004
    Messages:
    2,233
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    SW London/Surrey borders
    Ratings:
    +63
    Since replying to this post, my Loewe Xelos has arrived. I am having incompatibility issues between the Xelos and my HDMI equipped DVD player. Until this is resolved, I cannot recommend this model for DVI/HDMI connection to a DVD player unless you try it out first with your model player and a disc other than Lord of the Rings - this and DVD, plus a selection of DVD-A discs are the only discs that I have sofar got to work.

    This is a shame as it has an excellent picture, much better than I witnissed on Sharp or Philips for Freeview/D-TV.

    -Ian
     
  4. ianh64

    ianh64
    Active Member

    Joined:
    Aug 7, 2004
    Messages:
    2,233
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    SW London/Surrey borders
    Ratings:
    +63
    OK. Problem resolved, not sure how, maybe a loose connector or a config issue. Anyhow, Im glad that I can recommend the Xelos again.
     

Share This Page

Loading...