Sharkoon XTatic - tuning?

Golfpunk

Active Member
Got myself a pair of these cans and am disapointed with the sound quality considering the price. I don't think that I have them tuned very well so interested in what other people have their settings at. It seems to me that they really lack bass?

Also, I get very audible pops and whistles on the optical input from the 360. Is this also usual?
 

roygbiv6

Active Member
Got myself a pair of these cans and am disapointed with the sound quality considering the price. I don't think that I have them tuned very well so interested in what other people have their settings at. It seems to me that they really lack bass?

Hi there not sure what you mean here by tuning as I just plugged them in & they were fine. I had to change 1 setting to make sure that DD was on & that was it. Also I've not noticed any lack of bass when playing games.

You could try messing with the volume settings to get the sound you're looking for.

If its any help mine are on Volume 3 for the rear & front & Volume 5 for the central speakers. On the control box I have the 1st switch at CTR & the 2nd at Vol/PL. I have the rumble volume on 0 but if you turn that up I think it adds something.

Also theres a setting on the dashboard :System/ Audio/ Digital Output. Make sure the DD 5.1 option is selected.

Also, I get very audible pops and whistles on the optical input from the 360. Is this also usual?

That's definitely not right.

Have you taken off the little plastic thing on the end of the optical cable? It sounds like a problem I had with mine before I realised you're supposed to take that bit off. Was driving me crazy.:suicide:
 

Golfpunk

Active Member
I can hear these noises they are very faint tho and I cant hear them when Im playing just when theres no sound from games/films.

Thanks - glad its not just me but its not very good for this price of kit. Also the power supply makes a load buzz and gets really hot after 30 mins or so. Might RMA them at this rate.....
 

Dyer

Standard Member
/\i get the same thing with mine those clicking noises are horible i also get funny robot noices as well, not very impressed by these headphones tbh.
 

Deputy Dawg UK

Active Member
i've got these, had them a while and use them at night and when the Missus is working from home....i think these are terrific...not sure of my settings but may try the above
 

Psychic 5

Well-known Member
Got myself a pair of these cans and am disapointed with the sound quality considering the price. I don't think that I have them tuned very well so interested in what other people have their settings at. It seems to me that they really lack bass?

Also, I get very audible pops and whistles on the optical input from the 360. Is this also usual?

I know the post was two months ago but I used to have a pair of these and I'd recommend to anyone uphappy with the sound levels to perform a reset (the manual explains how to do this) as I once found I'd totally tuned out some of the speakers without realising :rolleyes:
 

shagaboopon

Well-known Member
I get interference through optical too with a different amp when my optical cable is not inserted all the way in at the 360 connector (its loose and falls out a little sometimes). I'd suggest trying another optical cable first.
 

ajcham

Active Member
I got these a few weeks ago, and I have been pretty impressed, so much so that I use them all the time when I am playing games where hearing the direction from certain sounds originated is useful (RSV, Gears, etc).

Although I have no doubt that a cheap surround set up would blow the socks off these headphones, they are a pretty good piece of kit.

The supplied Toslink cable clicks in properly into the XBox AV cable for me...
 

Psychic 5

Well-known Member
I've lost my manual...how do you reset them ????

You can download the manual from the Sharkoon web site,

page 19 hold down B10 and B11 while the control station is turned off, then turn it on by pressing B8 and the leds B13, B14 and B15 will flash three times to confirm the reset.
 

garnat

Active Member
I got a set of these for xmas and I am also getting background noise. Even with the phones turned on and no output from the xbox there is a noticeable background noise. When is use I can hear a kind of digital beeping in the background. I've tried resetting them and am using the supplied optical cable to connect directly to my xbox 360.

Is this normal or might there be something wrong with them?
 

Deputy Dawg UK

Active Member
I've had these for about a year now and never had any problems with them at all...I do occaisionally here a beep (or something similar) but it never affects the sound quality.
 

qfk123

Active Member
I just got a set of these and some far about 85% impressed but i think im having trouble getting them to a level where its acceptable for most things im always having to tune then to what im doing, gaming, music or dvds.

( Can not believe there is no central volume, just settings for the individual speakers - bizarre )

most of the settings are on about 4-5 and the subwoofer rumble of about 3-4- did put toy story dvd on which had the thx sound optimiser on it. guess they need bit of fiddling. But did try them on the ps3 and they sounded better/ cleaner.

Any updates of how people are finding these- would like to get a better optical cable and a splitter so headphones can be also plugged into a ps3 without losing quality.
 

The latest video from AVForums

Movies Podcast: Star Trek in 4K. Is the new boxset worth it?
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom