Setup MediaPortal with Sky/Freesat and DJBlu's amazing EPG Grabber in just 30 minutes!

MonkeyJug

Active Member
Good job! Sorry didn't reply sooner.

I agree with mik, stick with 1.7 - I tend to only upgrade on even numbers as there is usually never anything that important that is worth the effort...
 

flexi

Standard Member
Thanks for the guide, downloaded and tried it out last night, in the most part I have been able to get everything working, even the time lag on changing channels is as quick as WMC which I have never been able to achieve when I tried mediaportal previously. The issue I have hit on is with the epg there is not any data populating for quite a few channels, does the data have to be mapped to each channel individually or should it have just worked like the channels which the data does populate for?
 

MonkeyJug

Active Member
If you left it turned on overnight, it should have populated anything that was missing automatically.

But you're right, it should grab 100% of the data initially. Historically, for whatever reason, I have noticed that the grab doesn't always grab 100% on first attempt, so what I usually do is grab twice (consecutively) during the initial setup and that has always worked.

I might amend the guide to reflect this...
 

flexi

Standard Member
Thanks, I gave that a try but still no joy. Is there anything else I can try?

I have tried changing my region etc to no joy. When in the TV server section I hit grab, the data shows it has collated epg information, but bar a small handful of channels, the epg is always completely empty.
 

MonkeyJug

Active Member
Try this:

1. Run the uninstallfilter.cmd command from an elevated command prompt
2. Drop the database by typing drop database mptvdb; from mysql command prompt (password is MediaPortal)
3. Delete all files in the TV Server/MDPlugins folder
4. Start again from installfilter.cmd point

Then when you get to the grab step, grab it twice in a row, ie. as soon as the first grab finished, click grab straight away again. See how that works..
 

flexi

Standard Member
Okay have given that a go, but now have another issue, when I select the preview point with the 10 channels I am not able to preview the channels anymore. I attempted to run the grabber anyway but I either receive an unknown error or no signal received message. I know there is a signal on both tuners, if I run WMC live tv works perfectly, also when I do the 10 channel scan in MP I receive a signal for both tuners. I am at a bit of loss now on how to resolve this one, everything I have tried does not appear to make a difference. Should I just try a re-install from scratch?
 

MonkeyJug

Active Member
Weird. That is the exact same problem jaipal2004 had. He resolved it by installing v1.71 from here:

http://forum.team-mediaportal.com/a...a-grabber-and-series-link-v-1-7-1-zip.150448/

With that release though, you will need to manually download and place the two plugin .dll files.

Custom Data Grabber goes in MediaPortal TV Server folder and SKY UK Grabber goes in MediaPortal TV Server/Plugins folder.

You can download those from here:

http://forum.team-mediaportal.com/attachments/custom-data-grabberv1-0-0-3-zip.87312/

http://forum.team-mediaportal.com/attachments/sky-uk-channel-and-epg-grabberv1-4-0-6-zip.135238/
 
Last edited:

MonkeyJug

Active Member
Guide simplified, updated and tested working for MediaPortal v1.9 - enjoy!
 

jimbob19

Active Member
You sir are a star :)
Works a treat -- my 2 year old MP with djblue and mdapi went T**s up and my backup was also corrupted .
Just reinstalled with your guide :)
I remember the last time I had to do it , it took weeks of research and trial and error
And it did take approx 30 mins :)

Many thanks
 

MonkeyJug

Active Member
You're welcome mate - glad you found it useful.
 

david230

Active Member
Hi MonkeyJug,

Hope you can help - Do you know of any reason why the skygrabber would move my dish when using the scanner? I have tried with the diseqc completely off, yet it still wants to move the dish everytime. I had to store 28.2 just so I could get it back to position each time.

thanks in advance!

David
 

MonkeyJug

Active Member
sorry david - no idea mate!
 

spacemanc

Active Member
Great guide and much needed. It's a shame DJBLu never did this for his own plugin. It fact it almost used to annoy me that he didn't make it more user friendly, but then how can you be annoyed when he put in all the hard work to make it happen.
 

MonkeyJug

Active Member
cheers spacemanc - you were the one who kicked it all off for me after seeing your mediaportal screenshots over 2 years ago!
 

JDR82

Well-known Member
Cheers for the guide, built myself a HTPC on Wednesday and along with a TBS-6982 Card I had Media Portal up and running perfectly within about 10 - 15 mins and then setup through Kodi in another minute or two.

The only thing I am trying to do is re-order my channels and have media portal and koi then pickup the new order for their EPG's, I have changed my channel list on the TV server software, but it doesn't seem to carry through to the clients, have you managed to adjust yours at all?
 

MonkeyJug

Active Member
for my openelec (kodi) client in the garage, i created a separate channel tab (called xbmc) in mediaportal, and then pointed openelec to this tab, but it should still work with any channel tab. there is however an option in openelec to 'sort channel order by backend order' (or similar), which maybe you have overlooked?

regarding mediaportal, in my favourites tab when using the epg, they are ordered exactly as they are in the tab during tv config. if i change the order there, it is reflected in the mediaportal epg - not sure why it's not sorting it for you...
 

JDR82

Well-known Member
Ah cheers will check for a backend option in Kodi tonight, I made a new group as well and pointed Kodi to that, hopefully I get this last setting working then its all perfect.

Cheers for the reply.
 

spacemanc

Active Member
cheers spacemanc - you were the one who kicked it all off for me after seeing your mediaportal screenshots over 2 years ago!

Yeah I remember. My setup is still going strong (I'm still playing it safe on 1.5!). I'm about to start tinkering again though with some Fire TV kodi clients.
 

JDR82

Well-known Member
Quick thanks, I had missed that option, channels now organised how I want them, just some skin stuff to continue tweaking then all done :)
 

mrrodge

Active Member
Is anyone else having trouble getting the EPG to update using the DJBlu plugin? I use it to view FTA channels and find that every week or so I have to manually grab the EPG using the TV-Server config. It doesn't wake the machine to grab and using the every 3 hours setting it doesn't seem to grab either. Puzzled!
 

spacemanc

Active Member
Auto update hasn't worked for me for about a year. Like you I just do a manual grab about once a week. I've tried setting it as a scheduled grab and a periodic grab and it makes no difference, but even before it went completely, I don't think I ever got the scheduled grab to work.

It's not a major problem for me, apart from when I've gone on holiday and people have looked after the house, it can be complicated to explain to them what to do.
 

JDR82

Well-known Member
Just to check as I haven't been running this a week yet, why do you need to keep doing an EPG grab, is this specifically a Media Portal thing, or is it something I will need to do running the MediaPortal XBMC addon?
 

spacemanc

Active Member
This is specifically a DJBlu plugin thing - it's where his plugin grabs the EPG data from the Sky feed.
 

MonkeyJug

Active Member
i've never had to do a manual grab in over 2 years of using it. not sure why people do - i think it affects people who turn their systems off at night or something...
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel

Latest News

Magico announces Titan 15 subwoofer
  • By Andy Bassett
  • Published
Ajax Systems adds UK Socket to expand smart home options
  • By Andy Bassett
  • Published
Best TVs of 2021 - Editor's Choice Awards
  • By Phil Hinton
  • Published
Melco update improves N10, N100 and N1 EX digital libraries
  • By Andy Bassett
  • Published
Loewe launches We.See TVs under new 'We. by Loewe' sub-brand
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom