1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Seleco SVT-195 Problems - Dealer parts?

Discussion in 'Projectors, Screens & Video Processors' started by gchq, Aug 13, 2005.

  1. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi there

    I have a ten year old Seleco SVT-195 that has given service above and beyond (no idea how many hours they should last for but..). For a while when first switched on it would 'hiss,' be out of focus and the colours were all over the place - 15 mins later it would be fine. I knew it was coming, and tonight it didn't correct itself. So, the question is:-

    1. Has anyone come across this fault before and know what component might have failed.

    or

    2. Know the UK dealer for Seleco? (I've slept since I installed it and set it up)

    Thanks for any assistance you can offer!
     
  2. Anders B

    Anders B
    Standard Member

    Joined:
    Jan 11, 2005
    Messages:
    42
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    Seleco is now Sim2. Dealer and service in UK by Owl Video Systems.
     
  3. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for that :) ! Owl does ring a bell now you mention it. Oddy enough after powing it down and leaving it for 30 mins it worked perfectly well, and has done since - even without the prior warming up problems - 'hissing' has gone as well. Have a feeling it may be the electrical focus unit (or dry joint on it).
     
  4. AD Roser

    AD Roser
    Active Member

    Joined:
    Aug 23, 2002
    Messages:
    280
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    East Sussex
    Ratings:
    +17
    FYI Owl no longer handle SIM2 and have not done so for over 2 years, however they may still have some parts remaining for the 150/195/350/400/500's.

    You can find out by speaking to their service dept on 01825 766123.
     
  5. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks Alan. Who do handle SIM2 now? Is the 195 still supported (insofar as new parts go)?
     
  6. AD Roser

    AD Roser
    Active Member

    Joined:
    Aug 23, 2002
    Messages:
    280
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    East Sussex
    Ratings:
    +17
    We do - but CRT products continue to be handled by Owl.
    To be honest parts for the 150/180/195 are no longer available from us - the manufacturer.
     
  7. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I think I have now isolated the fault to the red tube! Owl no longer stock any parts for Seleco products and B4 Projection neither answer their phone or respond to emails. Since the kit has now clocked up somewhere in the region of 12k hours (against estimated tube life of 9k hours) looks like I'm up for three tubes - CRT Sony 5.5" 70 Degree! Any ideas where I might locate these?
     
  8. mintminty59

    mintminty59
    Standard Member

    Joined:
    Jan 19, 2005
    Messages:
    55
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I have 4 to 5 of these units 150 . In bits around my house. Your welcome to buy any bits you need althought I dont trust the power supplies in then (start up and trip into standby)
     
  9. Mad Mr H

    Mad Mr H
    Well-known Member

    Joined:
    Jun 10, 2005
    Messages:
    4,430
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    London
    Ratings:
    +280
    HI,

    Give B4 another try - Maybe Roland is on holiday or away working on CRT's - hes very helpful.

    As for parts I might be able to help.......

    I have a 190 here which I will check but I think I can part out (upgraded by customer and sitting here waiting a sale - which is never gonna happen!!!, ex home cinema NOT pub install....)

    to be honest im not sure the 190 is worth the retube/repair.

    Why not look to upgrade to a better seleco?

    the 450's and 500 are good...........

    yes you can still get them!

    OWL dont have any seleco stock at all.
     
  10. Jonesthegas

    Jonesthegas
    Active Member

    Joined:
    Jun 5, 2002
    Messages:
    633
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Newcastle upon Tyne
    Ratings:
    +19
    Roland has been away. He's back now.

    Martin
     
  11. Mad Mr H

    Mad Mr H
    Well-known Member

    Joined:
    Jun 10, 2005
    Messages:
    4,430
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    London
    Ratings:
    +280
    Im guessing he's been with you.......

    You lucky lucky lucky person :D

    post some pics of the 919

    Dont make me BEG! ;)
     
  12. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Where are you located?

    Red tube now keeps going out of focus - bit of a pain!
     
  13. Mad Mr H

    Mad Mr H
    Well-known Member

    Joined:
    Jun 10, 2005
    Messages:
    4,430
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    London
    Ratings:
    +280
    That could be the neck board not on the tube 100%

    switch it off, leave it for a few hours

    open case, check ALL tube neck boards are on 100%
    They shoud be firm.

    Thats if you mean in and out of focus all the time every say 5 seconds.

    OR did you mean convergance NOT focus?

    Could also be faulty focus block

    give some more details....
     
  14. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Current symptoms are - after switching on red tube does not start at all for about 30 mins and the other tubes are way out of focus. When the red kicks in the others have focused but the red is way out - tonight they are ALL out of focus. Convergence doesn't seem to be a problem, but I have noticed the horizontal red moving from time to time - I thought perhaps the electonic focus unit.

    Any ideas would be appreciated

    Thanks
     
  15. gchq

    gchq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    OK - took the thing down and investigated - where the cable from the electronic focus unit runs to the tube it has shorted out (beyond repair) on the block that connects to the tube, so I need the printed circuit board that fits to the tube - anyone got one they can sell me before the MWS (Movie Withdrawal Symptoms) get too serious?

    Thanks
     
  16. Mad Mr H

    Mad Mr H
    Well-known Member

    Joined:
    Jun 10, 2005
    Messages:
    4,430
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    London
    Ratings:
    +280
    Parts in post to you.

    :thumbsup:
     

Share This Page

Loading...