SD memory card blank?

windymiller68

Active Member
I have a few SD Memory Cards that I use predominatly with my Nikon Digital Camera. I now have an issue with one card, a 128mb Kingston.

I take pictures and they are saved on the card. When I come to transfer the pictures to my computer via my usual card reader, the computer recognises the 'Removable Disk F' in both the USB icon in the taskbar and in 'my computer'. Yet under properties there is 0mb storage.

I reformatted the card via my camera, took a picture, put the card back in the reader, in the computer and the Wizard in XP picked it up straight away and I saved the picture to a folder through the wizard. With this I thought I had solved the issue and went out and took some pictures only to get back and have the same problem as before, no recognisable data on the card.

Is the card scrap?

Is their anything I can do to
a) resolve the problem
b) save what pictures are on the card.

Many thanks in advance as always.
 

BrokenArrow

Active Member
Can you try connecting the camera to the PC via USB and transferring the photos over like that? It may be the card reader. If they show up on the camera but not on the PC it's most likely something getting in the way of transferring them.

It could be worth just buying another memory card for peace of mind. They're only about £6 for 2GB these days. That's if you don't have much storage anyway. If you do have lots of other, good sized SD cards, just avoid using the 128mb one. :)


Edit: Just thought, do you have the "lock" switch on the card switched on? I can't remember if it can stop you accessing it or not but it's worth checking. :)
 

windymiller68

Active Member
Lock switch is in the off position.

I have a 2gb and a 1gb card as well. I have tested them and they both work fine with the card reader.

If I can find the lead for the camera/usb I'll have a go with transfering the card whilst in the camera.

When using the card in the camera, everything will lead you to believe that all is ok. Images are saved on the card as normal. The fault only came about when I took it out to transfer them to my computer. It's a shame as it's on me a lot and comes in handy regularly.

I think it'll have to be another new card?
 

patmok88

Standard Member
you got another card you can test it with? if another card its fine then your card is probably broken :(
 

MikeK

Well-known Member
Is it defo an SD card?

My old card reader would read SD cards fine, but strangely refused to look at the supposedly compatible MMC cards (two old ones I had).
It had to go when it later also refused to look at 1GB/2GB MicroSD cards in adapters!

New card reader reads them all!

Just a thought!!
 

windymiller68

Active Member
Yes they are all definitely SD cards.

Yes I have tried other cards.

They all worked.

Now only the 128 card will not transfer to the computer.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom