Screen or Y-Buffers?

timjamesz06

Novice Member
I have a 42" Panasonic that just keeps on ticking (10 years old now). I have had to replace several boards in the thing (so far, signal board and D-board [logic board]). While the thing is still working about as well as I could ever expect a 10 year old plasma to work, there is a screen artifact that is pretty minor, but it's driving me nuts from a diagnostic standpoint. I see it most prevalently on areas of the screen that are fairly dark and was able to best capture it when I had the screen displaying a less than totally black solid background (dark grey). The artifacts themselves are tiny horizontal lines of varying length and about a pixel tall. Based on what I know, I tried some obvious fixes like re-seating all the ribbon connections on my screen buffers (both sides). This had no effect. I also had a spare Y-SUS board lying around (thought my original was bad at one point and picked up a replacement that wasn't actually needed). Swapping those boards had zero effect. I am running the TV off my PC at the moment (over HDMI), so I messed around with all the various video, color, refresh rate, image enhancement filters, etc, etc on my graphics card and while a lot of those had effects on the TV picture, they had no effect on the artifacts. I tried running off a different source altogether (xbox over component video) and the artifacts remain. I went through all the picture options in the TV menu and none had any effect on the artifacts. I did find it interesting that I'm seeing these things in a definitive pattern (see close up photo) across the entire screen. I have a feeling that's diagnostically relevant, although I'm not totally sure how.

I am left with the conclusion that it's either bad Y-Buffers (probably both) or the artifacts are actually living inside the ICs that are integral to the screen. I can pick up a pair of Y-Buffers for $30, but I really hate to even put another $30 toward this TV unless I am 99% certain that would resolve the issue, and at the moment, I am not even close to 99% certain. Obviously a screen replacement is out of the question. It's been a point of pride keeping this thing running, so I thought I would at least try and get some other opinions on the matter. See some photos below (one I had the flash on so you will have to zoom in to see the issue in detail). And in the photos below, this is sort of the worst case scenario. Under typical viewing circumstances, they aren't nearly that noticeable, although in dark scenes, they can become fairly obtrusive. Thanks in advance for any input.



 

timjamesz06

Novice Member
Actually, this is a Toshiba Plasma, don't know why I thought it was Panasonic. Maybe because most manufacturers share so many internal parts. It's a Toshiba 42HP95.
 

The latest video from AVForums

Podcast: Best Hi-Fi products of 2020, Plus Best of the Month for TV Shows & Movies
Top Bottom