Save my Hard Disk! (sata to usb?)

ddvmor

Active Member
Hi, all.

My PC has recently died. Despite my utter lack of skill with it's innards, I'm reasonably certain the problem lies with the motherboard and not with the hard drive - on startup, the hard drive never gets accessed.

I want to take it into a computer shop to see what can be done about it, but before I do, I want to back up the data on my hard drive - in particular the photos. I have a 350gb portable had drive and a laptop that I can use for this.

Unfortunately, due to the location of the screws, I can't extract the hard disk - my plan was to pop into Maplin or PC World with it and ask them if they have a cradle or a set of cables o something that I can use to hook it up to my laptop via usb as an external drive. As I can't get it out, I'm presented with a minor problem.

I can see SATA-USB converter cables on amazon and ebay and similar but I'm not usre what I need. My question to you all is this. Based on the photos below, are you able to point me to the right bit of kit (preferably from amazon as I can get free next day delivery! :) )









Thanks in advance for your help! :smashin:
 

Andy98765

Distinguished Member
If the PC boots into Bios but then stops it could one of two things.
A Bios setting has got changed that now tells the motherboard Bios to look somewhere else for Windows, this is common with Sata drives or a fundamental problem with the Power supply.
 

ddvmor

Active Member
Hi, Andy. It doesn't even boot into BIOS. The power unit's working, but that's about all!

I'm mostly looking to rescue my data before letting someone in a shop do the hard work! :)

Edit: Does this look like it'll do the job?
 
Last edited:

jetinder

Novice Member
Never used it my self but that will do it.

If your motherboard doesnt boot it could be a number of things.

Inc cpu failure.

Have you tried to take the battery out of the motherboard and put it back in to reset things ?
 

Andy98765

Distinguished Member
The power unit fan maybe working but the actual supply rails have gone. Nearly every power unit I have had to change the fan works and gives every indication it is working but it is not. Through friends and family I have changed at least 5 units like this.
So before tearing your PC apart try borrowing a spare unit first. The symptoms you describe indicate to me to look at the power unit.
 

ddvmor

Active Member
Never used it my self but that will do it.?

Excellent. Thanks for that! :smashin:

Have you tried to take the battery out of the motherboard and put it back in to reset things ?

I have - someone suggested that to me shortly after the event, but it didn't make any difference! :(

Irritatingly, it died about 3 weeks out of warranty!:mad:

The power unit fan maybe working but the actual supply rails have gone. [...] So before tearing your PC apart try borrowing a spare unit first. The symptoms you describe indicate to me to look at the power unit.
Thanks - I shall see if I can scrounge one! :)
 
Last edited:

ddvmor

Active Member
Quick update - I picked up a bit of kit very similar to the one I linked to above from Maplin and it worked a treat. All my data is now backed up safely! Thanks for your help guys!

I'll try the power unit thing over the weekend - hopefully that's all it is! :)
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom