Sata Problem

S

Sarah Nya

Guest
Just a little problem I'm getting with the new PC...

It recognises my hard drives as I and J, this causes problems as by default Windows seems to think C is the master drive, and C happens to be what it has blessed my card reader as!

Thus when I go to install something it defaults to the card reader and I have to manually retype the path to get it to install on the correct drive.

How can I change things around, I've looked in the Bios and it seems to have assigned my Hard drives as third primarys but I don't know how to change them.

Help...
 

Andy98765

Distinguished Member
The problem all started when you built the PC. By plugging in the USB card readers the BIOS allocated then first.
When building a PC you should never plug in card readers until the operating system is built.
 

one_grim_reaper

Novice Member
To reassign drive letters go into control panel - administrative tools - computer management.

When here go to disk management on the left and in the right all your drives should appear. If you right click them you can choose 'change drive letter and paths'.
 
S

Sarah Nya

Guest
Ah well, is there an (easy) way to rectify this?

Grim I've tried changing the name that way but it won't allow me to :(
 

Andy98765

Distinguished Member
Not tried this, but maybe you need to more the drive assigned to C: first before moving your Hard drive to this position.
 
S

Sarah Nya

Guest
I will mess about with it when I get home, I'll let you know how it goes.
 

Uridium

Well-known Member
Andy98765 said:
Not tried this, but maybe you need to more the drive assigned to C: first before moving your Hard drive to this position.
You can't move the Boot partition without using aftermarket software such as Partition magic and I still wouldn't recommend it.

Best off disabling the Card Reader and doing a clean build
 
S

Sarah Nya

Guest
So I just take out the card reader and install windows again?
 

HMHB

Distinguished Member
I've had this kind of problem before when card readers and even zip drives have been connected during installation and you can't easily change the install drive letter as someone else has already pointed out.
Now when I do installs I make sure I just have the bare minimum hardware connected up for the first part of the install, so that would be just the one hard drive and CD/DVD drive - this way you are more likely for windows to recognise the hard drive as C:
I do hope that Vista is clever enough to get over this problem and the problem of having to use drivers on a floppy drive to enable it to see a SATA drive for installation !
 
Use to happen on an IBM machine I had, but then I changed the board to an Asus one, have 3 hard drives connected, memory card reader, 2 dvd writers on seperate IDE cables, all my hard drives were SATA, and i just set the one I wanted to be the boot drive as the First Hard Drive in the BIOS and it is always the C drive every time I reformat, no need to unplug anything, it's really down to the BIOS you use the Asus one uses an AMI Bios had two boards with that and they allow you to customise alot of stuff, so if you can live with unplugging all your drives when reinstalling windows then go for it, but if not change your mobo to an Asus one..
 

Similar threads

Top Bottom