• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

SATA HDD no longer recognised

cunnas

Distinguished Member
Hi all
I have a Windows 7 system and have been running it on a 500GB Seagate SATA HDD for months now. I have never had a problem until this morning when I turned the PC on, the BIOS splash screen showed and then I had an odd message along the lines of "Please insert a bootable drive"

When I finally managed to get in to the BIOS I checked the Boot order and the SATA devices and for some reason my HDD wasn't shown.

I unplugged the SATA cable and power and tried another SATA cable and power and still no joy.

I am going to try and plug the HDD in to my work PC tomorrow.

Does it sound like the HDD has just died as it does not seem to be getting any power?

There are a few things that I haven't backed up but nothing too major so other than the cost of a new HDD it is no real loss. Just annoying that it has been working perfectly and then suddenly nothing! Any ideas?
 

nheather

Distinguished Member
Could it be something to do with the SATA access method in the BIOS (AHCI or IDE).

If set to AHCI when you install, then the AHCI drivers will be installed and drives detected.

However, if the installation was done when this setting was IDE, then no AHCI drivers will be installed by windows.

If you subsequently change the BIOS setting to ACHI then the drives won't appear - because it only displays IDE drives (or IDE emulated) in the main pages.

Also, note that when in AHCI when you look in the BIOS, the drives don't appear to be there (on my BIOS anyway). When booting you will get something like AHCI (press Alt-F6 for details). If you do that, it lists the SATA drives that the BIOS knows about.

May be nothing to do with this in your case but worth checking.

Cheers,

Nigel
 

cunnas

Distinguished Member
have tried it on another PC as a second SATA drive and also in a SATA USB caddy and still nothing. Have come to the conclusion that it's dead!

Luckily, I checked on the Seagate site and it's still in warranty so they will replace it. Won't get the data back though which is a bit of a shame but no major harm done!
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom