1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sanyo Tech Support NEEDED!

Discussion in 'Projectors, Screens & Video Processors' started by springfieldict, Jun 7, 2005.

  1. springfieldict

    springfieldict
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Right,
    I have a Sanyo PLC-SW15 (PRO-X) PJ that is not responding at all, ie, no lights, fans, anything. I have reset the thermal trip inside, replaced the lamp, cleaned filters, opened her up but it looks fine inside, pressed the reset button on the case, everything.
    It's just over 3 years old. Has it had it's day? It was working fine up until the point it just turned itself off! Someone please help before I throw her in the bin. :thumbsdow
    Thank You.
     
  2. Maff et1

    Maff et1
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Sure the power cable is OK?
     
  3. hornydragon

    hornydragon
    Well-known Member

    Joined:
    Dec 19, 2001
    Messages:
    28,293
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Somewhere near the M4 most of the time......
    Ratings:
    +1,215
    are you in the UK?
     
  4. cyberheater

    cyberheater
    Well-known Member

    Joined:
    Apr 3, 2003
    Messages:
    3,190
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Scotland
    Ratings:
    +174
    How did it stop working. Was it working fine and then you switched it off and then the next time it didn't switch on or did it fail whilst projecting.
     
  5. springfieldict

    springfieldict
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    The Power cable is fine as I have checked several, the socket itself seems fine ie; there are no obvious breaks from the board.
    I believe it was turned off at night and wouldn't turn back on.
    And yes I'm in the UK.
     
  6. hornydragon

    hornydragon
    Well-known Member

    Joined:
    Dec 19, 2001
    Messages:
    28,293
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Somewhere near the M4 most of the time......
    Ratings:
    +1,215
  7. springfieldict

    springfieldict
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks, I'll give them a try

    The same thing happened before and we sent it back to Sanyo as it was still under warranty and they said all they had to do was 'reset' it. I thought that would be the thermal trip.
     
  8. Maff et1

    Maff et1
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0

Share This Page

Loading...