Sanyo plv z800 projector

BayleafTheGardener

Novice Member
I put my projector away at beginning of May .It was working absolutely fine.

I make do with the 55 inch portable over the summer months. I always have done this for the last 11 years.

Other than replacing the lamp on 3 occasions, it's original, like triggers broom.

However, I went to use it yesterday. And I get a screen display as shown.

This happens after about 5 to 10 minutes and last s for about 30 seconds to a minute. Then the picture goes back to normal.

This continues for up to 45 minutes. I then gave up and went back to watching the portable.

Has anyone got any ideas.

Kind regards

BayleafTheGardener
 

Attachments

  • 20210923_094045.jpg
    20210923_094045.jpg
    205.4 KB · Views: 23

BayleafTheGardener

Novice Member
Well after speaking to a couple of projector companies re a repair. I was quoted up to £500 . Think I paid 1200 for the projector ,around 12 years ago . So I was beginning to think it was time to say good bye to the trigger's broom of the projector world. I know there are plenty of projector there with far better specification.

However, in a dark room , the plv z800 still gives , in my opinion good picture.

As as the problem was intermittent I decided to try a new hdmi cable. This seemed to make the problem less frequent. So I'm thinking it's the av receiver, where the problem lays. I've owned the vsl 303 for 2 years.

So I went for a factory reset .

And , touch wood, for the last 2 days , now problem with the display.
 
Last edited:

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom