1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SANYO PLC-SW15 please help!!!!

Discussion in 'Projectors, Screens & Video Processors' started by springfieldict, May 11, 2005.

  1. springfieldict

    springfieldict
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,
    I have a Sanyo PLC-SW15 (PRO-X) projector which has been working fine for about 3 years. Last year it just died (ie. no lights or fan or lamp on) As it was still under warranty, we sent it back and they apparantly 'reset' it. It has recently died again though this time it's not under warranty. I have tried a new lamp in it but still nothing. I have cleaned filters. I have pressed the reset button and opened it to see if it was anything obvious (there are no more reset buttons or fuses etc in there) Has anyone got any idea how to 'reset' this or otherwise get it alive again?


    :lease:
     
  2. ptek

    ptek
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    check thermal fuse, located internally near lamp cage, it has red button on top and is resetable by pressing (disconnect power first !), usually trips due to poor air flow (dirty filters) or poor ventilation,
     
  3. springfieldict

    springfieldict
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    tried that and it still doesn't work. The thermal trip was a bit 'spongy' so I even tried bypassing that, because I thought that may be faulty, with a wire and croc clips but still no joy. It will be dumped unless I can fix it which would be a shame. Any ideas? The prices for sending them away to be looked at let alone repaired cannot be justified, does anyone know anywhere I could send it which is more reasonable?
     

Share This Page

Loading...