Samsung tv won't turn on via HDMI CEC or Alexa

ScottyG48

Novice Member
Hi,



I’m new to AV Forums but needing help if possible please. My set up is:

Samsung UE50TU8500

Shy+ HD box

Firestick 4k



All working fine, including HDMI CEC switching on TV when I switch on Sky. Then just before Christmas I introduced a Sonos Beam Gen 1 – still okay for about a fortnight, however lip sync wasn’t great. So I tried Optical rather than HDMI Arc, just the same. Back to HDMI Arc and found pass through, which fixed the lip sync issue. BUT the Sky box would no longer turn on the TV. I have tried very combination of soft reset/hard rest covering Sky box, TV and Sonos and nothing will bring back the auto switch on feature. This includes all the various settings within both Sky and my TV, including Input Plus, Anytime+, HDMI CEC etc.



So now I have to switch on Sky, use long press (which used to be short press) to turn on TV, then the Beam takes a while to start playing audio, longer than initially. I can use Alexa to adjust the Beam’s volume and to play music, but it WILL NOT switch the TV on or off. Throughout this, I’ve had some success where everything works for a few minutes, but switch off for an hour or so and the auto-switch on fails again.



I need ideas please! First, to bring back the HDMI CEC switch on feature. And/or, to use Alexa to switch on instead, which would probably do as a Plan B!



Any thoughts? I’ve replaced the HDMI cable between Sky and Samsung.

Thanks!!
 

ScottyG48

Novice Member
And as a weird follow-up I've just discovered that if I'm patient, the long press to start tvcwill also start the Sky box. Which is almost a solution but is SO SLOW! Sky box still not kicking TV into life.
 

roylion15

Standard Member
Hello
The Skill "Smarthings" Alexa does not work to turn on your TV if it is connected to internet by cable, it only works on wifi.
You can use WOL Skill to turn on the cable TV. Wake on Lan Alexa Skill, it works great for me ...
Alexa, turn on "device name" chosen in WOL Skill.
 

ScottyG48

Novice Member
I'll give that a go thanks very much. I've now spent almost 3 hours on calls to samsung trying to fix this set. New problem- I've lost all my apps and the tv now refuses to reinstall them. In warranty so could be going back soon!
 

roylion15

Standard Member
Did you try to RESET SMART HUB from the Settings menu > "Support" > "Self Diagnostics" > "Reset Smarthub" ?
 

ScottyG48

Novice Member
Hi, I couldn't access it! So have just spent another 50 minutes with samsung before the technician could access it, reset smarthub and it's fixed! Thanks for the tips, much appreciated!
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom