Samsung TV not switching to HDR10+ for blu rays?

philzee86

Novice Member
Hi Everybody,

I was having a problem with my Samsung TV (RU8000) that I found a solution to. I couldn't find the problem being discussed online, which made finding a solution difficult. Since I now know how to solve the problem, I thought I'd share both the issue I was dealing with and the solution, so others don't have as hard a time as me.

My TV was not switching to HDR10+ for blu rays - when I would check the quick settings, it only said "HDR" under picture mode, but not "HDR10+." I was using a HDR10+ compatible player (Panasonic DP-UB420) to try and watch Alien on 4K, as well as Dawn of the Dead on 4K (both of which are HDR10+ discs). I was also using an 18gbps HDMI cable. The player was recognizing both discs as HDR10+, and was saying that it was outputting in HDR10+, but the TV's quick settings would still only say "HDR" and not "HDR10+" as it should. I had no problem streaming HDR10+ content, but for some reason, it just wasn't kicking in for the blu rays.

After talking to a very unhelpful agent on Samsung's Online Chat Support who hung up on me when I was checking the picture settings they told me to check, I was left to find my own solution, and find it I did. For some reason, I had to actually disable Input Signal Plus. To do so, simply go to Settings>General>External Device Management>Input Signal Plus, and then turn it off for the appropriate HDMI input. Once I did this, the quick settings for Picture Mode displayed that it was using HDR10+, and not just HDR.

So there it is. A problem I had, and the solution I found. Did anyone else have this issue? Was this the same solution you found, or did you find some other one? I hope that this will be helpful for someone, someday.
 

The latest video from AVForums

Podcast: Best Home Cinema Sources and B&W 805 D4 Speaker Review and more...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom