Samsung Q90T - some HDMI sources display black screen after turning TV on

vokamax

Novice Member
Hey guys, been running into a really annoying issue after receiving my Q90T yesterday.

After I turn the TV off when on certain HDMI sources (firestick and android tv box), then turn the TV on again I get a black screen with a loading icon, then 'No source detected'. When I check the sources screen, the android TV box has a red icon on it, but the firestick looks normal. I have to keep pressing buttons on the Firestick/Android TV remote and then it appears after 5-10 seconds.

I've realised that this happens when I've enabled Anynet+ (HDMI-CEC), and when it's disabled, I don't run into this issue anymore. However, I'm then unable to connect my Sonos Beam via ARC and have to go with the ol' optical port instead which isn't ideal, and then can't use the other remotes to control the TV.

Anyone run into a similar issue and know what the fix is? I've checked google and some people have said this happens because the TV sends an 'off signal' to all connected HDMI devices when the TV turns off, but then there's no settings to change this so not sure what else to do. I've tried using different HDMI cables, and resetting the TV etc. but nothing works, and I'm starting to think this is a feature of the TV. Thanks guys
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom