Samsung PS50C96HDX covered in shinny blue pixels

Discussion in 'Samsung TVs Forum' started by PhAtTs79, Jan 16, 2008.

  1. PhAtTs79

    PhAtTs79
    Standard Member

    Joined:
    Jan 14, 2008
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    hi guys! i'm pretty new to this forum but i have been here a few times looking up reviews for TV's and on quite a few peoples recommendation i got myself a C96HDX while it was on offer in September last year

    now, i found going from a rear projection 43" toshiba to the 50" was a MASSIVE improvement and i havent looked back and up until now its been a sweet buy but...

    i got home last night and turned on my xbox and TV and to my horror the image was tainted by evil blue pixels scattered all over the screen (main "press start" screen on CoD4) but mainly in the top corners and seemed to be moving along with the clouds - you guys that have this game may know what i'm on about, but other AV sources seemed fine

    i tried adjusting the contrast, brightness, screen size, DNi etc etc but no difference and the problem was getting worse but the minute?! turned it off then on from the main but still the same! played with the component cables on the back to check if proper contact was being made but no change...
    i then turned my eye to the xbox in my last breath of hope, off the on but again the same, switched the cable to standard TV and was fine... maybe the xbox?? so on that note i switched it back to HDTV and ta dah, blue pixels have vannished?!

    i've had the odd pixels showing through before watching DVD's but never playing a game and never on this scale, was almost replacing colours it couldnt reproduce? the problem seems sorted now but i've got feeling i'm gonna see those critters again so your advice would be appreciated!

    would it be the TV or does it sound like the xbox playing games? its an earlier xbox (the ones prone to the ring of death) but i've had no problems with it thus far

    your advice, reassurance etc etc is much needed!

    cheers guys!
     
  2. kjt2004

    kjt2004
    Active Member

    Joined:
    Dec 16, 2005
    Messages:
    1,762
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Surrey
    Ratings:
    +165
    Hi

    Sorry but my guess is voltage/ pcb problems does it occur on all inputs just to confirm if its just xbox you may be lucky

    regards
     
  3. eiren

    eiren
    Distinguished Member

    Joined:
    Oct 12, 2007
    Messages:
    11,242
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    166
    Ratings:
    +2,796
    If it's just on the XBox, sounds like the GPU on it might be on its way out.
     
  4. PhAtTs79

    PhAtTs79
    Standard Member

    Joined:
    Jan 14, 2008
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    its just seems to be on the component which is what the xbox is plumbed into and as my Sky seems fine (a little grainy but i suppose thats poor reception) i'm feeling its either the 360 or the component on the TV

    since i switched the AV lead on the xbox to standard then back to HD it appears fine, it is one of the older 360's and i think it is one of the older ones that have the GPU overheating problem so i'm hoping its on its way out so i can get my hands on one with HDMI

    is there much difference in visual quality between HD component and HDMI on the 360? sorry, off the subject but out of interest ;)
     
  5. ced70

    ced70
    Standard Member

    Joined:
    Mar 10, 2009
    Messages:
    6
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I would say its heat.
     

Share This Page

Loading...