Samsung LCD TV Black Screen (Weird!)

HerculesDK

Novice Member
Dear Board of AV experts and enthusiasts,

I have a Samsung LCD LE40A856 Full HD TV, which I bought in 2009. The TV has been working fine, but I noticed that there was a line down in the left side of the panel, when I did a cold boot up that disappeared after 10 minutes or so. This was not really an issue, but then I moved and have not used the TV for long. The times when I did turn it on it worked fine. But for some weeks ago I had to connect my PS3 to the TV using the HDMI port and it started to act funny. It just showed a black screen when I tried finding the PS3 and started to freeze in the menu. But the TV signal was fine. The freezing got worse and the TV started to operate very slowly so I switched the TV off. Since then it clicked a few times with a black screen and I haven’t been able to test the sound. The panel sounds work, but there is nothing on the display. This is what I have tried so far:

1) Checking the capacitors – I couldn’t find any faulty ones, but I changed them all on the power supply.

2) Checked and changed the two 450v 68uf ones also even though they looked fine.

After doing the above mentioned the situation is the same. I am starting to suspect that it might be the T-con board or the main board; however I do not have the means to test these. I did notice today that before resetting (it is in a kinda boot loop) the LCD TV does light op before shutting down. So I do not think that the panel is dead, which is good news (if I am right). The TV only clicks once on startup and nothing else. However, I noticed that the volume up touch sensitive button on the TV set on the front is blinking all the time. I’ve tried calling Samsung, but they did not know what it meant! I do believe that this is some kind of a diagnostic problem indicator, which I do not know the meaning of.
Is there anyone that can help me with my Samsung LCD TV set? The TV is unplugged at the moment, but I wish I somehow could reset the BIOS/firmware or the eeprom or so. It does have a Service port, but I don’t know how to use it? It also has an Ethernet port, but I don’t know how to use it in this situation.

I am in desperate need for help and guidance,

Yours truly,

/D
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom