Samsung HW-Q90R Soundbar Review & Comments

BohamCY

Active Member
I have a strange one, all is working fine until last week.
Whenever I turn the bar on, the sub does not work.
The only way I can get it to work is to turn off one surround speaker

Either one will do but it seems I can only have 2 things linked at a time. The third won't function.
 

Brigdenius

Novice Member
I have a strange one, all is working fine until last week.
Whenever I turn the bar on, the sub does not work.
The only way I can get it to work is to turn off one surround speaker

Either one will do but it seems I can only have 2 things linked at a time. The third won't function.
Have you updated everything to the latest firmware? This happened with mine when I first set it up without the update. Had to update the rear speaker and subwoofer separately.
 

San5324

Active Member
I have a strange one, all is working fine until last week.
Whenever I turn the bar on, the sub does not work.
The only way I can get it to work is to turn off one surround speaker

Either one will do but it seems I can only have 2 things linked at a time. The third won't function.
Sounds to me u didn't update. U have the problem most people talked about before the update.
 

BohamCY

Active Member
Updating was the first thing I did
1007.9
I read the problem before the update was things randomly disconnecting but that's not what I have and at first there were no problems
Only after a few days things stopped working
 
Last edited:

San5324

Active Member
Updating was the first thing I did
1007.9
I read the problem before the update was things randomly disconnecting but that's not what I have and at first there were no problems
Only after a few days things stopped working

That's odd, the only problem I had was losing Arc con and I fixed that by totally powering down TV and bar, take out all cables and drain the temp battery of the TV. After 30 min I switched everything back and it was fixed.. Maybe try the same????
 

BohamCY

Active Member
Full reset seems to have done it :)
Still playing with the settings but no matter how I position the rears, or how I set the volume levels, the rear heights never sound above me, always to the side/behind.

My seating is almost against the wall but there's a small ledge behind it, tried behind me, to the sides, ear level, above ear level, but the test tones and helicopter demo always sound like they're coming from the rears instead of above.

Fronts work beautifully though.
 
Last edited:

San5324

Active Member
Full reset seems to have done it :)
Still playing with the settings but no matter how I position the rears, or how I set the volume levels, the rear heights never sound above me, always to the side/behind.

My seating is almost against the wall but there's a small ledge behind it, tried behind me, to the sides, ear level, above ear level, but the test tones and helicopter demo always sound like they're coming from the rears instead of above.

Fronts work beautifully though.
I have the same situation, my rears are directly behind my sofa... Try my settings

Treble +4
Bas +2
Front side centre +3
Behind rear & up +6
 

BohamCY

Active Member
I have the same situation, my rears are directly behind my sofa... Try my settings

Treble +4
Bas +2
Front side centre +3
Behind rear & up +6

how far away are your rears from your ears (ba dum pssshht)
Are they above ear height?
Do you have your "virtual" setting on or off?
 
Last edited:

San5324

Active Member
how far away are your rears from your ears (ba dum pssshht)
Are they above ear height?
Do you have your "virtual" setting on or off?
I have virtual on yeah.. They are on the standards I bought for them and they are directly behind the sofa.
 

Cozza53

Novice Member
I have had the Q90R for about a month and have to say the sound quality is amazing. However I’ve have numerous ongoing issues even since updating the firmware.

I have my Sky Q box connected directly to the soundbar and then from the Arc to my Sony Bravia tv. Often I will turn them all on and it’s just a blank screen like there’s no signal coming from the Sky Q box. Once I reset the box it tends to start working again. Sky have said the issue isn’t the box, and the problem only started since I added the sound bar.

Anyone had any similar issues? It’s got to the point where despite the amazing quality sound I’m thinking about returning the sound bar.
 

sukhy5

Active Member
I have had the Q90R for about a month and have to say the sound quality is amazing. However I’ve have numerous ongoing issues even since updating the firmware.

I have my Sky Q box connected directly to the soundbar and then from the Arc to my Sony Bravia tv. Often I will turn them all on and it’s just a blank screen like there’s no signal coming from the Sky Q box. Once I reset the box it tends to start working again. Sky have said the issue isn’t the box, and the problem only started since I added the sound bar.

Anyone had any similar issues? It’s got to the point where despite the amazing quality sound I’m thinking about returning the sound bar.
Same here. But when the Sky Q brings up the blank screen, I have tried and taken out the HDMI lead from Q90 and pugged it ino the TV (direct). Still no signal. Reset box and works again.
 

DJ Dunk

Active Member
I have had the Q90R for about a month and have to say the sound quality is amazing. However I’ve have numerous ongoing issues even since updating the firmware.

I have my Sky Q box connected directly to the soundbar and then from the Arc to my Sony Bravia tv. Often I will turn them all on and it’s just a blank screen like there’s no signal coming from the Sky Q box. Once I reset the box it tends to start working again. Sky have said the issue isn’t the box, and the problem only started since I added the sound bar.

Anyone had any similar issues? It’s got to the point where despite the amazing quality sound I’m thinking about returning the sound bar.

I think it is a Sky Q box issue personally. I have the same problem quite often if I don't put the box into standby before powering on a console and auto switching sources on my TV (Samsung KS8000). I don't have this soundbar (yet!) and my Sky Q box is connected directly to the TV's One Connect box, not even using ARC.

Having to reset the Sky box is a painful lengthy wait when the little ones want to watch TV.
 

Cozza53

Novice Member
Same here. But when the Sky Q brings up the blank screen, I have tried and taken out the HDMI lead from Q90 and pugged it ino the TV (direct). Still no signal. Reset box and works again.
Same here. When I plug the hdmi directly into the tv, still no signal.
 

Old Bill

Active Member
I read some other people a few pages back had the same problem. No clue here.
Finally solved the problem. For some reason Netflix does not use Atmos unless the soundbar is on adaptive mode. I watched Guardians of the Galaxy 2 and it changed to Atmos straight away. When I was in surround mode I had to switch to tv speakers and then back to the sound bar for it to kick in.
 

San5324

Active Member
Finally solved the problem. For some reason Netflix does not use Atmos unless the soundbar is on adaptive mode. I watched Guardians of the Galaxy 2 and it changed to Atmos straight away. When I was in surround mode I had to switch to tv speakers and then back to the sound bar for it to kick in.
U are lucky to have da on Netflix... I don't have that due to the fact I have a Samsung TV..
 

lesd57

Standard Member
Hi Steve

Love the in depth review.

One thing, I phoned Samsung who say the ARC is not eARC but standard Audio Return Channel. Do you know what is correct?
 

nulheim

Novice Member
I have purchased recently a Q90R soundbar, and after installing it seems impossible to connect with my iphone's spotify connect.

I have installed fw 1008 in soundbar and in subwoofer & rear speakers following the samsung's web intructions. SmartThings app shows 1008 version and the soundbar is properly added and connected to the same wifi network of my iphone. I can play spotify songs with bluetooth, but I cannot use Spotify Connect because the soundbar doesn't appear in the spotify's devices list, even with the soundbar in Wifi input. I have disable the option "Show only local devices", and my account is premium. With my computer and with my previous Yamaha receiver the Spotify Connect works flawlessly.

I have resetted the router, reinstalled spotify, reinstalled smartthings app (and granted all permissions it asks for), remove and re-add the soundbar to smarthings app, select Wifi input, and nothing.

Can you help me to make spotify connect works?
 

Steve Withers

Reviewer
Hi Steve

Love the in depth review.

One thing, I phoned Samsung who say the ARC is not eARC but standard Audio Return Channel. Do you know what is correct?
Hi Les (saw your tweet). Samsung has repeatedly told me that its 2019 soundbars will support eARC thanks to a firmware update released a few months ago. However some owners haven't been able to get it to work, so it's possible that the firmware update hasn't been released yet. I'll chase them up again and see if I can get a straight answer.
 

lesd57

Standard Member
Hi Steve

Thanks for that, much appreciated.

I am waiting for the delivery of the HWQ90R and would like eARC as a future proofing selling point. Do you think that if Samsung have not yet upgraded their ARC connection that the hardware is capable of this and that there is an intention to carry this out in the near future?

If not I may not purchase given its cost, it’s not cheap.

Thanks
 

sieucan

Novice Member
I have purchased recently a Q90R soundbar, and after installing it seems impossible to connect with my iphone's spotify connect.

I have installed fw 1008 in soundbar and in subwoofer & rear speakers following the samsung's web intructions. SmartThings app shows 1008 version and the soundbar is properly added and connected to the same wifi network of my iphone. I can play spotify songs with bluetooth, but I cannot use Spotify Connect because the soundbar doesn't appear in the spotify's devices list, even with the soundbar in Wifi input. I have disable the option "Show only local devices", and my account is premium. With my computer and with my previous Yamaha receiver the Spotify Connect works flawlessly.

I have resetted the router, reinstalled spotify, reinstalled smartthings app (and granted all permissions it asks for), remove and re-add the soundbar to smarthings app, select Wifi input, and nothing.

Can you help me to make spotify connect works?
In Smartthings
SmartThings Config (three dashes- Gear icon) -> Update wifi infomation -> select Your sound bar -> follow guide to reset Spotify
 

xrkt77

Active Member
Hi Les (saw your tweet). Samsung has repeatedly told me that its 2019 soundbars will support eARC thanks to a firmware update released a few months ago. However some owners haven't been able to get it to work, so it's possible that the firmware update hasn't been released yet. I'll chase them up again and see if I can get a straight answer.
Steve, can you also ask them if last years model the N950 will also get the eArc update as it was suggested by John Archer back in February that the N850 would get it as well.
 
Last edited:

Steve Withers

Reviewer
Steve, can you also ask them if last years model the N950 will also get the eArc update as it was suggested by John Archer back in February that the N850 would get it as well.
As far as I'm aware Samsung has no plans to upgrade last year's models with eARC.
 

nulheim

Novice Member
In Smartthings
SmartThings Config (three dashes- Gear icon) -> Update wifi infomation -> select Your sound bar -> follow guide to reset Spotify
Thank you sieucan, but in the Samsung official forum a moderator confirmed me that the Samsung soundbars are not compatible with Spotify Connect, so I've returned it.
 

nulheim

Novice Member
Sorry, but it is compatible. I am using it with spotify directly.
I don't understand anything: SmartThings app doesn't show Spotify, Spotify doesn't show soundbar in Devices list, in the official Samung forum a moderator says me that the soundbar is not compatible with Spotify Connect.... and now you tell me this. How did you get to configure spotify?

Well, in the end I have returned the soundbar and I return to my reliable Yamaha. Thank you Hoebsi!
 

Mr Carrot

Novice Member
Hi guys waiting on delivery of my 77 inch c9 which I will wall mount and have selected this to be the soundbar - any advice on how to wire this for minimum fuss and cable run covering - I don't want to have to plug and unplug cables that are wired through a wall after all!

I have seen a lot of people worrying about eARC issues and limited HDMI - should I continue to run cables into TV with EARC to the bar?

I only have two hdmi connections into the tv (Switch and xbox one x) as I can't get sky or virgin in my property (City of London).

For owners what colour is the supplied rear speaker power cables (I presume black) what's the length are there any generic white 2 pin plug cables that will work with them?

Like this:

https://www.amazon.co.uk/Flexson-Power-Cable-Right-Angled-White-UK/dp/B07JGF5KQH/ref=sr_1_5?keywords=Flexson+Sonos+play+extension+lead&qid=1568456012&s=gateway&sr=8-5


Final question is there any recommended wall mounting bracket for the rears you guys have found for the rear speakers (I take it ear height is best height?)
 
Last edited:

NatFlenders

Active Member
Hi Les (saw your tweet). Samsung has repeatedly told me that its 2019 soundbars will support eARC thanks to a firmware update released a few months ago. However some owners haven't been able to get it to work, so it's possible that the firmware update hasn't been released yet. I'll chase them up again and see if I can get a straight answer.
Any update you received from Samsung?
 

Trending threads

Latest news

McIntosh releases DA2 Digital Audio Module Upgrade Kit
  • By Andy Bassett
  • Published
Sky TV offers cheaper Sky Q box with updated features
  • By Andy Bassett
  • Published
Fyne Audio unveils its first home install loudspeaker line up
  • By Andy Bassett
  • Published
Best TVs of 2019 - Editor's Choice Awards
  • By Phil Hinton
  • Published
AVForums Podcast: 18th November 2019
  • By Phil Hinton
  • Published

Latest threads

Top Bottom