Question Samsung HW-N950 Sound Cutting Out Using ARC

Turok117

Novice Member
Hey Everyone,

First time poster here, looking for some help. About a week ago I purchased a new LG OLED65B8 TV and a Samsung HW-N950 soundbar to go along with it. I have the soundbar connected to the TV using the ARC connection (via Rocketfish 18Gbps HDMI cable) and then have a Blu-Ray player connected directly to the soundbar as well. I have played 3 UHD discs so far, all with Dolby Atmos, with no issues. However, when I try and play any Dolby Atmos streaming content using the native TV apps, the sound cuts in and out horribly. The soundbar is recognizing it as Dolby Atmos content, based on the soundbar display. I tried three different shows/movies on Netflix and one show on Prime Video, all with the same result. When I play any non-Dolby Atmos content on either app the sound plays with no issues.

Another note is that I tried playing Punisher Season 1 just a couple days after I set everything up and it played fine, and I believe it is Dolby Atmos. In between then and when I tried it again with the resulting sound issue, I downloaded the Samsung SmartThings app and I think it automatically updated the firmware on the bar so I am wondering if that is possibly the root cause of my issue.

Anyway any help/suggestions or even someone else having the same issue so I know I'm not crazy would be appreciated.

Thanks!
 

antsims

Distinguished Member
I’m on latest software and have no issues with LG TV apps using Atmos over arc. Make sure the audio on Netflix is selected as the best option rather than an auto. I had to do this online and not through the TV Netflix app. I did also make sure I uninstalled and reinstalled the Netflix app on the tv as I was initially having issues. After performing these changes it worked fine. Might be worth also changing hdmi cable as these can often be the source of issues (regardless of make or price you paid for them). I use amazon basics and they work perfectly. Hope this helps.
 

Turok117

Novice Member
I’m on latest software and have no issues with LG TV apps using Atmos over arc. Make sure the audio on Netflix is selected as the best option rather than an auto. I had to do this online and not through the TV Netflix app. I did also make sure I uninstalled and reinstalled the Netflix app on the tv as I was initially having issues. After performing these changes it worked fine. Might be worth also changing hdmi cable as these can often be the source of issues (regardless of make or price you paid for them). I use amazon basics and they work perfectly. Hope this helps.

Thanks for the reply. I tried everything you described with no change. I was able to narrow something down though. Within the LG TV sound output setting for ARC I can change between the AUTO or PCM. When it is on AUTO the sound issue is present but the soundbar recognizes it as Dolby Atmos and when it is on PCM the sound is fine but the soundbar doesn't recognize it as Dolby Atmos.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom