Samsung HW-K950 Connectivity issues

Discussion in 'Soundbars, Soundplates & Soundbases' started by victor64, Apr 19, 2018.

  1. victor64

    victor64
    Novice Member

    Joined:
    Aug 23, 2014
    Messages:
    11
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +2
    Hi all. Have lost connectivity to the Woofer and Atmos speakers somehow. I've read prev posts and have followed all auto and manual options. I've also tried updating the firmware via USB but nothing happened...Is there any way of identifying what version of firmware I have? And is there any way of getting this latest firmware (SAT-HAK16WWC) loaded via the internet to the Soundbar instead of USB? I see this vers. firmware deals with connection issues so would like this loaded. IE What do I actually do to get it loaded? There's nothing specific on Samsung sites unfortunately and I'm not much cop with the technical stuff... Thanks
     
  2. victor64

    victor64
    Novice Member

    Joined:
    Aug 23, 2014
    Messages:
    11
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +2
    I've now downloaded samsung multiroom app and updated soundbar with firmware, but still no connectivity...out of warranty now, so am out of luck it seems, bother..
     
  3. yan101

    yan101
    Active Member

    Joined:
    Oct 28, 2013
    Messages:
    61
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    How long have you had the kit? Ive returned a tv in the past after a firmware update rendered it useless, this was almost 4 years after purchase and went back to the manufacturer for replacement.... with a newer model as, lets face it, 4 years later that model was defunct. Not saying that should be your first port of call but worth considering. Electronics are meant to last 6 years according to trading standards
     
  4. victor64

    victor64
    Novice Member

    Joined:
    Aug 23, 2014
    Messages:
    11
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +2
    I've only had it nine months, but it was officially sold as a refurb, because the brackets for the Atmos speakers were missing, unit itself was brand new..both Samsung and vendor are saying 'too bad'..
     
  5. yan101

    yan101
    Active Member

    Joined:
    Oct 28, 2013
    Messages:
    61
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    Even so, you still have statutory rights for it to be working. They cant just say too bad because it was a refurb.
     
  6. synecdoche

    synecdoche
    Novice Member

    Joined:
    Jan 17, 2014
    Messages:
    7
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Ratings:
    +1
    Have you tried a re-init? Switch on, hold down the settings button (the one with a gear on it) on the remote for what feels like forever. It'll show some info on the display and restart.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice