• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Samsung HT-F6500 Blu Ray speaker connectors

Dexter987

Novice Member
Hi. Recently had painters in and blu-ray player must have got kicked around or something. The centre speaker and both surrounds don't work anymore.

All cables and speakers themselves are fine, it's just the ports that they plug into on the player itself.
IMG_20170712_153253.jpg


I opened the unit to see if there were any cables that I could easily fix but it is one solid unit that connect all the ports to the board.
IMG_20170712_153356.jpg


Any thoughts on what I can do next?
 

Peter Parker

Distinguished Member
Hi. Recently had painters in

You shouldn't be posting such marital issues in a public forum :p

Have you proved it's the player and not the speakers at fault by plugging the centre and then the surround speakers into the left and right output and see if they work or not?

Have you checked to see if there isn't a stereo output mode that's been selected? That would explain why only the left and right speakers are working.
 

Dexter987

Novice Member
I'll keep my personal issues to myself so :)

It's definitely not a problem with any speaker or speaker cables, but you could be onto something with the stereo output mode. Would the subwoofer work with the left and right if it was in stereo? I'll check that this evening when I get home
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom