• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.
  • Black Friday Deals
    Visit our Black Friday page for our frequently updated, hand picked deals on TVs and other tech.

Samsung HT-C450N 5.1 ch -Surround Sound problems

hardinandyork

Standard Member
Hi, I wonder if anyone can help me. My Samsung system has been operational for about three weeks without problem. It has now started to make a noise (like a poorly programmed radio) when I fast forward Sky + recordings, but the main problem is delayed sound.It can take a minute or so for sound to appear when I change channels, also yesterday no sound came out of the speakers at all when I switched the system on. I turned everything off and then it did start up.
Any help would be greatly appreciated.

MT
 

billmoodytwo

Standard Member
I am having similar problems with a HT D450. When first connecting to the TV with optical connection it can take up to 1 min to start up. But I still have poor sound sync. The sound is delayed enough to notice on screen….but I can only delay the sound….not speed it up. I spoke to Samsung yesterday….the say there is a fix to download….will try it next week when I get time…..but really could do without this !
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom