S21T TFT problem "no signal"

keskri

Standard Member
Hi
I have a problem with the TFT on Origen S21T.
It just looks for DVI (Why DVI since there are no DVI input...) and states that there is "no signal" and just just goes black after a few seconds.
The menus are not accessible at all, not from the remote or buttons on the side of the screen.
Has anyone had this problem?
Seems that I want to do some sort of reset on the TFT. But how since the menus are not reachable?
The touchfunctionalty works OK.

I have tried with other sources from other computers just to eliminate the possibility that something else is broken.

Look forward to get some help in this situation.
 

keskri

Standard Member
Hi
I have the same fault as you have did you have any luck working out how to fix it ?

Cheers
Dave

Hi Dave.
Since I had an original TFT Origen could not solve the problem.
Had to buy a new one from them :(
But please submit a support case at their site to see if they can handle your problem .

BR
/Krister
 

spyder viewer

Distinguished Member
If there is a fundamental problem with the design of this product, then owners have additional rights under the sOG act.
 

belongamick

Active Member
I stopped using the TFT screen on my Origen S21T as randomly caused Windows 7 to bluescreen. Never had any use out of it unfortunately.
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom