Ruark R1 backpack

ian ccc

Novice Member
Hi, can anyone help me please. Had a ruark R1 for about 4 years and the backpack battery seemed to be losing its power more and more so I’ve just bought the newest version, I’ve fitted it and the green light keeps flashes and not charging ( like my old one )
If I plug the R1 into the wall it works fine( without power pack attached)
Yet I’ve charged the new backpack with a different adapter and the light stays green. But when I’ve refitted the battery there’s no power.
I’m thinking I may need a new adapter. Can anyone help please . Cheers
 

wine man

Standard Member
If you are sure the battery is correctly connected to the R1, then I would report your problem to Ruark - the new battery may be faulty. They are very helpful there.
 

ian ccc

Novice Member
If you are sure the battery is correctly connected to the R1, then I would report your problem to Ruark - the new battery may be faulty. They are very helpful there.
Thanks mate , I’ve give it back to John Lewis, there was fault on it , put my old one back in. Got in touch with ruark too , they were quite helpful. Think I’ll let this old one completely die before getting another. 👍🏼
 

wine man

Standard Member
No probs Ian, I have two of the old Vita branded R1 which are still going strong. Lovely sound quality from a small box!
 

ian ccc

Novice Member
I agree mate, it’s a big sound from a small unit. I like Ruark stuff , I’ve got a R4 also , produces a lovely sound and looks lovely (imho).
I just thought the sound loses a bit (R1) when it’s powered by my old battery after a while
 

Similar threads

The latest video from AVForums

Podcast: LCD TVs for Movies, Physical Discs?, RIP Ennio Morricone, AV & Movie news, B+W Matt Damon
Top Bottom