router just died

connor1

Active Member
MY D-link 524 died on my last night so I have no online play tonight :mad: I updated the firmware to enable DMZ?? for the ps3 which it said it did fine when it rebooted nothing. I cant get an IP address from it cant connect to the admin page. I am really annoyed as although the signal want great I could get online with it. I have tried all the reset options given on dlinks site inlcuding the crash reset and nothing. I have raised a fault with Dlink but Im not going to hold my breath, just ordered a netgear WGT624 so that should be here in a couple of days. Thankfully I still have my old netgear, which isnt wireless, so at least I can still get on the net.
 

Moogle

Distinguished Member
Are you sure you followed the firmware update procedure to the letter ? Sounds like you may have inadvertently bricked the router. If that is the case you may not get any help from D-Link's customer support.
 

connor1

Active Member
sure did. Downloaded the correct firmware verified it, the router came back with a successful update screen and then rebooted. I must admit I think the routers bricked but Im a bit annoyed that it was doing a flaming update. Lets hope we dont get anything like this with our PS3's
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom