• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Rotel A14 / Klipsch RP160M / SVS SB2000

rossman1903

Novice Member
hi.

I have the above setup. When listening to certain tracks I can hear a very faint crackle mainly coming in the left channel (or so it appears to me). There are no loose connections. The tracks don’t need to be particularly dynamic and there is no crackle soft or loud with certain very dynamic and bass heavy / full range tracks.

So my question is this: is it likely to be the case that the crackle is part of the sound recording and my system is picking up the flaw, or is it more likely that there’s something up with my system?

Many thanks!

Ross
 

rossman1903

Novice Member
I’m guessing from the tone of this response that my question was a dumb one.

Now I have to try to figure out what’s up with the system, which I was hoping to avoid.

Thanks for taking the time to reply in any event.
 

rossman1903

Novice Member
I’ve narrowed it down to the AirPlay Express hooked up to the Opt2 input. It’s neither the speakers nor the amp thankfully. This is a relief.

Anyone aware of crackle issues with AirPlay Express audio streaming and if there is a fix?
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom