Robbie Williams

Shady

Novice Member
Hi chaps

Anybody had any problems with Escapology ?

My first copy seemed to jump after about 10 seconds on many of the tracks - i.e. first line in 'Feel' etc.

I contacted CD-WOW about the problem and within 30 minutes had a reply stating that they would ship another copy. This arrived yesterday (CD-WOW - first rate supplier - customer service spot on - when you need to use them).

Tried the new copy and guess what - jumps in exactly the same spot. I am playing this in my car on the standard VW CD player. The cover of the CD does state that they have heaped on new security measures. Is this responsible.

Anybody else having the same problem ?

If it is due to the new security measures surely this is not allowable as I am not doing anything untoward and not receiving what I paid for i.e. a CD quality copy for something I have paid good money for.


Any ideas ?


Cheers
 
M

minimad

Guest
Have you tried the CD in any other player apart from the car?
 
S

Squirrel God

Guest
Originally posted by Shady
If it is due to the new security measures surely this is not allowable as I am not doing anything untoward and not receiving what I paid for i.e. a CD quality copy for something I have paid good money for.
You'd like to think it's not acceptable, but the truth of the matter is that the record companies don't give a $h!t!

As Minimad says, bit of common sense needed - try it in another CD player! If it works - great. If it don't -it's probably the copy protection.

My copy is on its way from CD-WOW and should be here in the next few days. If you haven't received any other replies by then, I'll let you know how I got on with it.

I did have problems with one CD I ordered from CD-WOW in the past. Both copies they sent me got "stuck" in exactly the same place. I told them that it was probably a faulty batch and asked them to send me a new one from a fresh batch. They replied stating that they have indeed unfortunately received a faulty batch of this particular CD. They sent me one from a new batch and it worked perfectly :)
 

oggy

Novice Member
My copy plays fine in the car & marantz cd player in the house bought from cd-wow as well.
 
J

juboy

Guest
Originally posted by Shady
My first copy seemed to jump after about 10 seconds on many of the tracks - i.e. first line in 'Feel' etc.
This is nothing to be concerned about. You obviously have one of the new breed of 'intelligent' quality control CD players that allocate an appropriate amount of playing time for each track on your CDs and then move to the next.

You may wish to get your CD player's software checked out though as I'm sure in the case of Robbie Williams' new CD, 10 seconds is probably on the generous side :D
 

Similar threads

The latest video from AVForums

LG CX 4K OLED TV Review: The best TV of 2020?
Top Bottom