1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roadstar DVD2551K (karaoke)

Discussion in 'Blu-ray & DVD Player Multiregion Hacks' started by harryharrison19, Jan 26, 2005.

  1. harryharrison19

    harryharrison19
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Does anybody know how to make this player region free?
    I bought it from Argos and cannot find a reference to it anywhere else on the web. There is a reference to DVD2550K is this the same?
    any help much appreciated.
    +
    Harry :lease:
     
  2. Blotto

    Blotto
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I don't know the answer to that, but my partner's just bought one through a catalogue too and I can't seem to be able to access the preferences menu, can you get into that menu? From there, you can set the TV type, ie UK, American etc. I think.

    MY PROBLEM IS:

    My partner bought a Roadstar DVD2551K the other day through a catalogue and it was working fine. The loading screen was a deep blue when you turned it on.

    I tried putting the DVD player through a scart junction box which is brand new, but which I hadn't used before for any other reason until now. This was so I could attach something else as an alternative AV source than the DVD, but I didn't actually try it with anything else plugged in and switched on, just the DVD.

    When I connected the DVD through the junction and switched everything on, the loading screen had a yellowish-green colouring to it and also any material played from disc had the same wierd tone. When I switched everything off and tried it without the junction box, the colour was normal again.

    I switched everything off and tried it again one more time to see if I hadn't plugged the scart lead into the junction properly. The screen now had a reddish tint to it! Now when I turn the TV to AV to use the DVD player, the loading screen has a yellowish-green colouring to it without the scart junction box! I can't access the Preferences menu to change the 'TV type' settings or anything in that part of the menu and I've checked and re-checked the scart lead attachments.

    I'd be very grateful if anyone can explain why this should this be happening? Should I send the DVD player back to Roadstar? My partner is going to be furious when she gets home!
     

Share This Page

Loading...