1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RGB on Hitachi 7500??? Seeing Red!

Discussion in 'Plasma TVs' started by stanleyntl, Aug 31, 2005.

  1. stanleyntl

    stanleyntl
    Active Member

    Joined:
    Dec 6, 2003
    Messages:
    806
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Worthing, Sussex
    Ratings:
    +44
    I previously had no RGB from a Pace 2400 SKY box (set for RGB) into AV2 of 42pd7500 Hitachi set - only a PAL composite picture.
    Ditching the Pace for a new DS430n Pace - I now get a Red picture upon switching to RGB.

    Supposedly this means either the Pace or Scart is only transmitting Red, or my Hitachi is only decoding the Red signal.

    Any suggestions from Hitachi plasma owners?
     
  2. stanleyntl

    stanleyntl
    Active Member

    Joined:
    Dec 6, 2003
    Messages:
    806
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Worthing, Sussex
    Ratings:
    +44
    :blush: Scart connector not seated properly, getting RGB on AV2 now, but not with old Pace box. Not blown away with RGB, maybe a better cable required - using Maplin OFC Scart (with metal Scart housings).

    Still puzzled as to why old Pace box didn't output RGB. :confused:
     
  3. MR.COATES

    MR.COATES
    Standard Member

    Joined:
    Mar 25, 2002
    Messages:
    148
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Scotland
    Ratings:
    +1
    I've ordered the Thor Scart from Play. One of my mates swears by them.
     

Share This Page

Loading...