Quantcast

Replacing headunit

zenden

Standard Member
Never done one before and thought it would be easy by pulling out the wires from the back of the old headunit and putting it into the new one.

BUT NO!

I pulled out the old headunit, there was a cable plugged in which i take it is the antena for the radio, and also pulled out the wiring loom from the back of the old headunit.


The new headunit i have has a different wiring loom connections, so i unplugged the old wiring loom (single block) and plugged in the new wiring loom (double block) and then plugged the loom into the back of the new headunit, i also plugged in the antena into the back of the new headunit.

But i have a cable which is ORANGE and splits into red/yellow which is sepperate from the loom but connects into the loom plug

And i also have a BROWN cable which is sepperate from the loom but then plugs into the loom connection

These were plugged into the back of the old headunit....


On the new headunit there is rear L/R connections that have not been plugged in (RED/WHITE) there are no wires for this but i have rear speakers?

Anyway i switched the headunit on with the present antena and loom plugged in and it sounded like the motor inside the headunit was turning but the display didnt come on.

What the hell am i doing wrong? i dont have any instructions with the headunit so i aint got a clue?

Anyone got any good tutorials with fitting a kenwood W4031 MP3 CD PLAYER into a corsa B 1994...

Cheers





OLD/NEW layout above...


Headunit is KENWOOD W4031 MP3 CD PLAYER
 

jtf

Novice Member
from what i understand from the pictures it looks like somebody has butchered your loom best book it in at you local car audio shop ( not halfrauds ) and get them to sort it out
 
Top Bottom