Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

rel q400 sub.help in setting up please

Discussion in 'Subwoofers' started by alwyn, Apr 15, 2003.

  1. alwyn

    alwyn
    Active Member

    Joined:
    Dec 10, 2002
    Messages:
    570
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    west country
    Ratings:
    +13
    I have just purchased the above and need advice. Do you connect the rel to just your pre amp,or do you olso connect the sub to your amps as suggeted by rel? I have been told that connecting to amps could affect their impedence.Is this true?
     
  2. magking

    magking
    Banned

    Joined:
    Jan 6, 2001
    Messages:
    380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Norway
    Ratings:
    +1
    As I have answered this several times i'll just give you a link to one of them.
    Look here.
    If you need more search for Q400 or post here.
    BTW, I have a Rel Q400 myself, but it retired now that i have a Velodyne HGS18, but it served my well.
     
  3. alwyn

    alwyn
    Active Member

    Joined:
    Dec 10, 2002
    Messages:
    570
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    west country
    Ratings:
    +13
    Thanks for your help.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice