1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rel Q150e

Discussion in 'Subwoofers' started by Tobez, Mar 14, 2003.

  1. Tobez

    Tobez
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Ok firstly my setup

    1x pioneer VSX 2011
    1x pioneer 757ai
    mission fs2 speakers in 7.1

    Ok the system was fine but lacked that earth moving BASS, so ive purchased a REL 150e, if anyof you dont know the FS2 speakers from Mission connect to the supplied SUB from mission but an unbilical coard that basically an extension cable, so all you cables goto the sub then a neat black cable goes to your amp. Because i got the new sub i thought if i remove the wires from the mission SUB and take them directly to the amp this should be ok, but what ive noticed is the centre speaker sounds hollow and tinni.


    Does the mission sub supply any low end backup to the FS2s will i have to run both REL and mission SUBS if so HOW ?
    disconnect LFE from MISSION run to REL ?
    and also connect HIGH level to REL vis RELS cable ?

    thanks
     
  2. Tobez

    Tobez
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Is Ok ive sorted it, THE FS2 speakers do need the sub from mission to supply there midrange and connot operate alone, i Have been advised by Mission to daisy chain the SUB which ive done, and it looks like my neighbours selling his house :)

    Tobez
     

Share This Page

Loading...