Recommendation for Heos and Qobuz users (with my Marantz PM7000N and BubbleUPnP)

mtenga

Distinguished Member
Strange, mconnectHD finds my Denon player no problem, and Denon is the sister to Marantz with similar implementations.

Anyway if you do get it working I’m not noticing much difference between CD and Hi-res on Qobuz. It’s all routinely excellent.
 

Razzyrazz

Novice Member
Been using Bubble and Qobuz for months without issue on my denon 6700. Lately after 20 minutes it fails and all I hear is very loud white noise. Almost like the encoding or decoding failed. Doesn't seem to happen when I use other apps thru Heos directly. Will test more. Anyone had this issue?
 

Cebolla

Member
A couple of test suggestions:
  • Does the BubbleUPnP Android app's own (local renderer) player have a similar issue with the same Qobuz tracks?
  • Does setting FFmpeg audio decoding to All audio formats (always use) for the Denon 6700 renderer's configuration settings on the BubbleUPnP app 'cure' the problem?
 

gava

Active Member
Mconnect does find my Sony smart tv as upnp device so it’s not my network or something like that

In my experience the fact that some things work and some things don't is not a very reliable guide as to whether everything is in good shape.

I can't really be bothered to spend a lot on sorting out a really high quality home network, but I do have a good (fairly expensive) dual-band wifi router and some ethernet switches.

Roon on my PC can never find anything and that seems to be because its network discovery is utterly crap.

mconnect sometimes can find my Marantz and sometimes not and I suspect it depends on whether my phone is using 2.4Ghz or 5Ghz wifi.

"smart" devices of various sorts can sometimes find things and sometimes not.

BubbleUPnP never seems to have any issues.

The problem with software which is designed to "just work" and doesn't allow any advanced configuration options with the networking is that when it doesn't just work you are stuck.
 
Last edited:

Razzyrazz

Novice Member
A couple of test suggestions:
  • Does the BubbleUPnP Android app's own (local renderer) player have a similar issue with the same Qobuz tracks?
  • Does setting FFmpeg audio decoding to All audio formats (always use) for the Denon 6700 renderer's configuration settings on the BubbleUPnP app 'cure' the problem?
Thanks a lot. This worked "setting FFmpeg audio decoding to All audio formats". Weird that it worked for months and then didn't but either way it works now. Thanks again.
 

Cebolla

Member
No worries.

However, the setting is only a workaround - the BubbleUPnP app is now decoding Qobuz's FLAC file tracks to uncompressed PCM (either raw or in a WAV file container) for your Denon. So you do appear to have a FLAC file decoding issue with the Denon.

It's possible that Qobuz may have changed how they encode their FLAC file tracks recently, which the Denon for some reason can't cope with after decoding & playing them after a while. Or, there's been no change by Qobuz and the Denon has actually developed a fault affecting its continuous playback of networked streamed FLAC file tracks.
 
Last edited:

Sluggster

Active Member
I want try Qobuz, as it seems to have more appropriate music for me.

I downloaded mconnect lite, which seems to work ok.

I liked the software so downloaded mconnect Player HD. It seemed to work yesterday and this morning but now my iPad can no longer find my AVR.

looking at this thread, it may be the router that is the issue.

I have the latest BT Router and use that and an Apple Airport Express to give stronger WiFi at the far end of the house. How could I make sure my iPad and Denon are on the same frequency At all times. The Denon is wired in and so is the Apple AE.

not sure if this is the problem, why Lite seems to work but HD does not. I just wonder if by chance the iPad chooses different frequencies depending on distance to the Router, maybe because of where I happen to sit.

Update: Both HD and Lite found my 8500 late yesterday afternoon and I was able to play music all evening. This morning neither the HD or Lite version can detect my 8500 this morning for music playing purposes. They do detect the 8500 as a server though. They also detect my Panasonic 4K BR player and my Shield via Chromecast For playing music and my Synology NAS as a server. All very frustrating.

Thanks,
Huw
 
Last edited:

Cebolla

Member
Even slightly unusual network configurations can cause problems with UPnP device discovery, if the network management system (eg your BT router) has issues supporting IGMP multicast (used by UPnP for device discovery).

I'd suggest using an SSID for the Airport Express that's different to your wireless router's SSID as that would ensure you knowing which wireless access point your iPad is connecting to and therefore help you isolate the problem. Also, for the same reasons, make sure that the BT router itself is also using different SSIDs if it's got both 5Ghz & 2.4GHz Wi-Fi enabled.
 

Sluggster

Active Member
Even slightly unusual network configurations can cause problems with UPnP device discovery, if the network management system (eg your BT router) has issues supporting IGMP multicast (used by UPnP for device discovery).

I'd suggest using an SSID for the Airport Express that's different to your wireless router's SSID as that would ensure you knowing which wireless access point your iPad is connecting to and therefore help you isolate the problem. Also, for the same reasons, make sure that the BT router itself is also using different SSIDs if it's got both 5Ghz & 2.4GHz Wi-Fi enabled.
Hi Cebolla,

Thanks for your response to this problem. On the following day, following an iPad restart, both HD & Lite connected. I hate doing anything related to networks - I don't understand them and so can't picture what I'm trying to do. The worst kind of problem is an intermittent fault and every network problem I get seems to come under that heading.

Anyway, the connections I was able to make convinced me that Qobuz was the way to go. I have also started the Roon trial and really like the look/feel and functionality of it. Of course, getting Roon running in HiRes is, in itself, a bag full of squirrels. With some help from a fellow member of AVForum I am off down the road of an RPi as a Roon End Point via a Topping E30 DAC into the analogue inputs of the Denon. It will be fun to see how that goes.

I'm going to start with my 2015 MacBook Pro as the Core and add my CD WAV/FLACs & Qobuz - I will use my iPhone 11 & iPad as controllers. If the Mac proves to be a problem, I'll get a NUC. Roon & Quobuz on an annual plan actually works out cheaper than Tidal by 50p. Of course, getting the other stuff put the price up a little ;-)

All seems to be working fine, apart from one issue. Every now and again the music will stop playing. Sometimes it is because a message comes up saying I have accessed iTunes (or similar) - was that you? I was surprised that stopped the Core from doing its thing TBH. Now and again, the music stops and there other related issues that I need to look into - hopefully, there will be info on the Roon forum. There may be network problems causing the songs to stop - the system seems to stop at the end of a song and every now and again the Core cannot be located after the song stops. On occasion, the song can not be restarted from the core front end. I hate this sort of issue!

I would also like to set up my Mac in Clamshell mode (lid shut) and have it permanently on my rack like a Mac Mini but that is not that easy to do if you want to turn the TV off or watch a BR film etc. Apparently, if you plug in a mouse and keyboard and shut the lid as it starts up, it will work but it can't just run in the background without a monitor. Hence maybe getting a NUC as a Core.

So it is going to be a fun few days.
 

mappel

Novice Member
Thanks so much!!!!
I set up everything for my Marantz SR6014 in a couple of minutes.
mconnect works flawlessly with Qobuz. Well worth the 7 Euros.
Just great! Keep up the good work!
Markus
 

mtenga

Distinguished Member
I’m using MConnect, Denon DNP800NE and Qobuz and find sometimes it can take 15 seconds to change tracks in a playlist. Sometimes it’s immediate. Can’t say for sure but I think it might be when I change from a Hi-Res to a CD quality track. Anyone else?
 

Vincenzooo

Novice Member
I have a marantz pm7000n, Qobuz and the mconnect app on my iphone.
I have the same issue: the marantz device is some times visible within the mconnect app to connect to via UPNP, sometimes not.
In my router i swicthed of the 5ghz band, to eliminate 2,4ghz vs 5ghz issues. Also, i switched on upnp on my router. It has some effect as i at least see the marantz pm7000n sometimes visible within the mconnect app. However, this is not always the case. It is sometimes visible, sometimes not.
When i DO have a connection from the mconnect app to my receiver via upnp, the app becomes very slow and in the end it will freeze. It takes 15 seconds to click and get a reaction within the mconnect app. So it works if you click one playlist and just leave the mconnect app. When you start browsing / clicking, it freezes or becomes slow in the end. But also this appears to be sometimes. So sometimes it works just fine.
So my experience is that the Marantz PM7000n is not able to stream via upnp reliable (or the combination mconnect / qobuz / marantz). Only airplay, spotify and heos app. But heos does not support qobuz.
What are other possible ways of getting my Qobuz music to my Marantz receiver without losing quality? What if I download the Qobuz app on my computer and use the audio jack output and just connect a audio cable from my laptop to my receiver? Is that hifi? I don't really trust it, as my system is >1K plus and then i use some sh*tty laptop audio jack to stream it via the cable.
Does anyone know what my options are to make sure i can listen losless quality with Qobuz and the Marantz PM7000N?
Thanks,
Vincenzooo
 
Last edited:

The latest video from AVForums

Podcast: Anthem AVM 70 Review, EQing Your Home Cinema Sound System and More...
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom