Receiver(Yammy RX-V630RDS) switching off when powered on!!

Discussion in 'AV Receivers & Amplifiers' started by bbanduser, Dec 23, 2003.

  1. bbanduser

    bbanduser
    Active Member

    Joined:
    Nov 22, 2002
    Messages:
    1,893
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Watford
    Ratings:
    +3
    Hi guys,
    Bought a Yammy RX-V630RDS Receiver from the classifieds forum. Strange thing is when powering it on it switches off after a few seconds on it's own !!At first I thought it was the speakers,so I disconnected all the speakers. So even now,when just the power cable is connected,it switches off after 2-3 seconds.

    Any ideas anyone, before I tear my hair out?
     
  2. geeWcee

    geeWcee
    Active Member

    Joined:
    Oct 27, 2003
    Messages:
    1,420
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    West Yorkshire
    Ratings:
    +26
    make sure that none of the exposed cable wires are touching (even slightly) each other either at the back of your amp or any of your speakers.
     
  3. bbanduser

    bbanduser
    Active Member

    Joined:
    Nov 22, 2002
    Messages:
    1,893
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Watford
    Ratings:
    +3
    As I said, I have detached all the speakers from the receiver,so there are no exposed cables anymore.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice