1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RD50 dead pixel ?

Discussion in 'TVs' started by marts00, Jan 1, 2005.

  1. marts00

    marts00
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Just noticed a small black dot near the bottom of my optoma rd50 screen.I thought it might have been a speck of xmas cake but no such luck.Is this what they call a "dead pixel" and will i have to get used to it being there.

    Anyone else with same tv got one or more?

    Cheers
     
  2. Razor

    Razor
    Member

    Joined:
    Dec 15, 2004
    Messages:
    37,548
    Products Owned:
    2
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +12,508
    No get it replaced. Optoma have a no dead pixle policy.
     
  3. weremog

    weremog
    Standard Member

    Joined:
    Nov 7, 2004
    Messages:
    25
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Peacehaven
    Ratings:
    +1
    Sorry, maybe I'm being a little dense here, but I thought that the LCD DLP rear projection technology didn't use a screen like conventional LCD TV's and therefore the dead Pixel problem can't occur?

    I'm happy for someone to put me straight
     
  4. Nick_UK

    Nick_UK
    Banned

    Joined:
    Nov 13, 2004
    Messages:
    9,748
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    103
    Ratings:
    +270
    The DLP system uses a chip which has 1.3 million mirrors, and each mirror is a pixel. If any mirror on the chip gets stuck, it's a dead pixel.

    For more explanations see this site
     
  5. weremog

    weremog
    Standard Member

    Joined:
    Nov 7, 2004
    Messages:
    25
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Peacehaven
    Ratings:
    +1

    Thanks for that
     
  6. GID

    GID
    Standard Member

    Joined:
    Dec 3, 2004
    Messages:
    31
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    hi marts00, I noticed 2 dead pixels after 4 days use. Still waiting to hear from Optoma about returning set because of NTSC problem.
     

Share This Page

Loading...