• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

RB81 Bi-Amping

ligama

Standard Member
Hi all,
I've just bought two Klipsch RB81 and I've connected using Bi-Amp to my Yamaha RX-V 661 (the ampli uses the surround backs channel in order to bi-amp the fronts).
In this moment the surround back are amping the woofers while the front are amping the trumpets ...
it seems it works (and I prefer vs normal amping) ... the question is "i've done properly?" (i've removed the bridges and I've activated the bi-amp function in the ampli)

Thanks
Mariano
 

BlueWizard

Distinguished Member
If it is working and you are sure all the (+)(red) on the amp are properly connected to the (+)(red) on the speakers, then it should be OK.

I've not worked a lot with multi-channel AV amps, but I think somewhere in the setup, you must tell the amp how you are using the channels. in other words you must tell the amp that you are either using the extra channels as standard full audio channels or that you are using them for bi-amping, and NOT using them for surround channels. Read the instruction manual for details.

Steve/bluewizard
 

ligama

Standard Member
I've not worked a lot with multi-channel AV amps, but I think somewhere in the setup, you must tell the amp how you are using the channels....

I've done this ... in the advanced menu of my ampli I've activated bi-amping and now surround back reproduce front audio.

thanks
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom