Range Extender Password problem - assistance please?


Novice Member
My broadband provider is SSE and they have recently replaced my router, albeit with some reluctance, following persistent problems with my Wifi not being recognised by Sky Q (new box sent without quibbling) or by my HP printer. I know that the router was faulty because I was able to temporarily restore Wifi service by piggybacking an old Sky router onto it using an ethernet lead. When the router arrived, I set about pairing all my devices (8 at the last count) with the new password provided and all was well.

I can get 50-60 mbps, which is more than sufficient for my needs, however I do use a Belkin AC750 DB wireless range extender just to help with reception upstairs, where my home office is situated. I can get the router to talk to the extender using the WPS function and the second channel now appears in the list of available networks. But when I attempt to connect any of my devices to this network it refuses to do so because the password is not recognised. Under my old setup, I was able to choose whether to connect to the upstairs or the downstairs network whenever I liked and the password was the same. I have reset the extender several times in an attempt to clear whatever memory it has; I have even tried entering the password from the previous router, but with no success.

Dr Google instructs me to log into Belkin.range but this site does not appear to exist. Other sites waffle on before advising the same, so in desperation I am turning to you guys - is there a solution or am I perhaps better off junking this quite old and inexpensive piece of kit and investing in a virginal new one, that might come with some actual instructions?

Update: in desperation I replaced the Belkin.range extender with a new one from TP link and guess what, I have exactly the same problem. When I go to connect with the new network, the password is not recognised. Surely it is supposed to be the same as the router's password? Does anyone read this?

Update: problem finally solved thanks to finding a similar query on a Netgear help site. Just a shame that none of the four methods of connection listed in the accompanying instruction leaflet actually worked.
Last edited:

The latest video from AVForums

Samsung S95B Update, B&W Panorama 3 & Q Acoustics Reviews, HDR PQ EOTF/Gamma Calibration Discussion
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom