random black dots on iscan hd+

donmonte

Standard Member
Hi everybody, it seems that when i connect my hd+ to my display be it thru hdmi or component, i get random black dots appearing and disappearing throughout the screen; but i could only see them if i was very close to the screen. At first i thought it was a problem with the dlp technology, but then i connected the pionneer 989 tru hdmi without the iscan and it was gone, i also tried connecting the hd+ to my hd crt thru component and the same thing happened.
What do you think might be the problem?
 

Ultima

Well-known Member
donmonte said:
Hi everybody, it seems that when i connect my hd+ to my display be it thru hdmi or component, i get random black dots appearing and disappearing throughout the screen; but i could only see them if i was very close to the screen. At first i thought it was a problem with the dlp technology, but then i connected the pionneer 989 tru hdmi without the iscan and it was gone, i also tried connecting the hd+ to my hd crt thru component and the same thing happened.
What do you think might be the problem?
I had exactly the same problem. The HD+ is faulty. I exchanged mine and the new unit doesn't show these black dots. Owl Video also confirmed the unit was faulty.

Regards
Martin
 

donmonte

Standard Member
Thanks ashworthacca, when you replaced your unit did you noticed an improvement in picture quality or was it the same picture without the dots?
 

Ultima

Well-known Member
donmonte said:
Thanks ashworthacca, when you replaced your unit did you noticed an improvement in picture quality or was it the same picture without the dots?
Yep, don't know whether it has to do with the unit or the new cables that I used on the new one though or the fact that I spent alittle longer setting it up.

The faulty unit was brand new and returned straight away even before I tweaked the settings so for a like for like quality comparison I can't really give an opinion if the quality was better because the fault was no more.

Regards
Martin
 

The latest video from AVForums

Podcast: Philips OLED+935 impressions, Denon AVC110 Review, Film Reviews, News and More...
Top Bottom