Question Questions for Bryston SP3 Owners

Mr Yakimoto

Active Member
Hi, Just picked up an SP3 but I have some questions that hopefully people here may be able to answer

The remote control (BR3), it only seems to adjust in 2db Units at a time, however I have noticed 1db units very occasionally, and once tonight I actually saw a .5db!! Is the remote faulty or is there something in the SP3 settings where I can change the remote signal to be in .5 rather than 2db?

The other question is to do with surround format. I have an oppo 203 linked via hdmi for audio. I have also linked my apple tv to the oppo 203 to take advantage of its hdmi audio connection

This is the strange part. If I play a film from apple, the IN states Dolby D /Dolby HD/DTSHD MA and the OUT states the same. If i play a disc, the IN states the above, however OUT only states 5.1 or 7.1, it doesnt state Dolby or DTS when the film starts. Whats happening here? Is there a set up issue, or does the unit have an issue?

I thank you in advance for any advise
 

JUS

Well-known Member
Hay, very late replying. I belong to a bryston Facebook group called “Our Bryston Audio”. It’s quite a happy relaxed group and has some very knowledgeable and Bryston experienced people, including staff. I’m sure someone on there could answer this or any of questions.
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom