Questions. About pulse 3d headset for ps5

Rvd150

Active Member
Iam very confused to buy pulse 3d or no

I didn't try any 3d headset before. I always using TV sound I never used any headset with game before .

My question is

.1- Is pulse 3d headset good and worth to buy?

2- is this headset make you feel. you in the game?

3- is this headset more realistic and fun than TV?

I need your advice
 
Last edited:

Rvd150

Active Member
i saw many videos says. i feel the sound coming from under my legs.. and now the sound coming from up my head . this make me inside the game 🤣🤣🤣🤣

Is this right ?? Or fake
 
Last edited:
Get a better set of headphones - you dont need thre pulse to get "3d" sound

"

Does PS5 3D Audio work with any headphones?​

Yes, the PS5 3D Audio is compatible with any stereo-based headsets or earphones. The technology used to create the audio soundscape comes from the PS5, rather than the headphones.
"
 

Don Rogers Tash

Well-known Member
I've got The Pulses and I'm very pleased with them.
I know The Arctics are better but if you shop around you can pick up the Sony's for less than 80 quid.
 

Rvd150

Active Member
I have original samsung earphones . And I tried it on ps5 I got no 3d . I got only sound coming from left and from right no more . Is the pulse 3d as this ??
 
Last edited:

Naqv

Well-known Member
I found them quite good but uncomfortable as they are quite rigid and feel like cheap plastic.
For not much more, you can pick up razer blackshark or Phillips x2.
 

Rvd150

Active Member
I want to know . This words is true or exaggerated words ???

As YouTube members said on reviews

i feel the sound coming from under my legs.. and now the sound coming from up my head . this make me inside the game
 

orlaithcullen01

Novice Member
Hello, looking some help with the pulse 3d headset. They don't seem to be charging on any USB device. They work fine on the laptop with the WiFi adapter connected and the charging cable connected. When checking battery level it beeps once with one purple light but still the same after connected for several hours. Have tried resetting also and still nothing. Any ideas? Thanks
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom