Q95T atmos sound on Netflix?

lgrenter

Novice Member
Hi, enjoying my mew Samsung 95T, but am having a strange atmos sound problem. The tv is connected to a 900t soundbar via earc, but when I launch Netflix or Amazon via its app I get no atmos sound option on anything offered. Have searched through content and even things like Witcher give no atmos logo on their info screens. Did a search online and someone recommended to reinstall the Netflix app, which I did. Suddenly I had atmos appear on info pages on Netflix but not Amazon. However, if I use game mode on tv for my switch, when I return to Netflix atmos has once again disappeared ! Once again a reinstall brings it back each time! Can’t work out how to stop it happening, atmos is chosen in tv sound settings etc so don’t know why tv does not show it automatically…. Also no sign of it on any Amazon content. Anyone know what to do?
 

Quelm

Member
Hi, enjoying my mew Samsung 95T, but am having a strange atmos sound problem. The tv is connected to a 900t soundbar via earc, but when I launch Netflix or Amazon via its app I get no atmos sound option on anything offered. Have searched through content and even things like Witcher give no atmos logo on their info screens. Did a search online and someone recommended to reinstall the Netflix app, which I did. Suddenly I had atmos appear on info pages on Netflix but not Amazon. However, if I use game mode on tv for my switch, when I return to Netflix atmos has once again disappeared ! Once again a reinstall brings it back each time! Can’t work out how to stop it happening, atmos is chosen in tv sound settings etc so don’t know why tv does not show it automatically…. Also no sign of it on any Amazon content. Anyone know what to do?
Just saw your post and it sounds like I am having the exact same issue. Only eARC connection but no Atmos. I am also using a Samsung Q70A TV with the Samsung HW-Q950A soundbar. Both are 2021 models with no other devices connected. Netflix does not show me the Atmos logo and when I play a known Atmos movie, the soundbar display only reads eARC when it should flash Dolby Atmos. Reinstalled the Netflix app but still same issue. Have you found a solution yet? I did a lot of reading and came across what might be an eARC/pass-through bug for Samsung. Hope this is not the case but I'm pretty new to this and I'm not sure that is exactly the same problem I'm having.
 

lgrenter

Novice Member
A reply here at last! Yay!
sorry to report that still having the same problem. Lately Netflix seems to have settled down and now seems to show the atmos sound logo on various items on its app. Still no idea if atmos is playing as the soundbar only reports earc on its tiny screen when I play anything reported as atmos. Have even tried different sound modes on the tv than adaptive to see if that makes a difference but no display change. Oddly I am unsure if the bar IS playing atmos as the sound in various items is excellent, just doesn’t show any confirmation. Checked on the tv itself on the settings bar when an item plays and noticed last night on Netflix that the sound setting auto changed from adaptive to standard for the film! Sadly I have no other devices to plug into it to see if the atmos works.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom