Q90T - How to stop the dimming in games? Video example provided.

Barrowulf

Novice Member
I've been continuously messing with the Q90T settings to get the best picture/performance in HDR games. Destiny 2 has been a real pain. Without getting into everything else I did, this is what I'm experiencing:


It drives me crazy. Whenever there's a bright sky or anything else, darker things around it get dimmed and crushed in black. Is there any way to fully disable this and leave the darker areas surrounding something bright as is?

I believe I've calibrated my TV as much as I could -- all eco settings and extra junk options are disabled. I even entered the service menu, but didn't change anything, since the two settings that users were saying to set to 100 were already at 100. Is there anything in the service menu that I can change to prevent all dimming?

I can provide all my settings if needed. I also used the HDR calibration tool on my Xbox and reset the HDR of the game, Destiny 2 (disabling HDR, setting brightness to default, enabling HDR again and setting those to default). Also, Local Dimming is set to Standard. It seems to do this on any of the settings, even Low. But, at least on Standard, the picture is slightly more vibrant. I also have HGiG enabled. Contrast Enhancer is set to Low, because I like the additional vibrancy, but the dimming still happens when this is set to Off as well. Also, this is in Game mode, but again, it still happens when in Movie mode.
 

mmj

Active Member
If there's an option in the game settings for maximum nits try setting it to 1000, I think I noticed something similar in a game when I had it set to 2000 or so.

If that doesn't work it might help to post all of your settings.
 

Barrowulf

Novice Member
Okay, thank you, I'll see if there's anything in the game related to that, or maybe even the Xbox HDR calibration tool. So, basically, I may have a setting too high that the TV can't display properly?

Do you know what could be causing the automatic dimming? I don't believe it's the dimming bug that some users were experiencing, because after six minutes the game still looks fine. It only dims when something bright is on the screen, like it's trying to enhance the contrast between the two.

I believe my firmware version is 1460. I saw there's a slightly newer version available if you download it to a flash drive, it hasn't made its way to the automatic download yet on the TV. But, some Youtubers I've looked up said it doesn't seem to do much at all and isn't something you need to rush and install right away.

I'll also compile a list of all my settings.
 

mmj

Active Member
I could be wrong I'm just thinking back to when I was experimenting with settings in AC, I think that I initially set max nits in the video options to 2000 nits because well... it's advertised as a HDR2000 TV but iirc it caused the backlight to dim quite aggressively, the TV is only really capable of about 1400 nits peak brightness (10% window) after calibration to D65 white point.

If that doesn't work HGIG may be what it is causing it, I only briefly enabled that and then quickly stopped using it, from what I've read Samsung's implementation of HGIG does not follow the proper standard anyway because there is some kind of mapping going on when there shouldn't be any.

I would just experiment with settings in the Xbox HDR calibration settings, in-game settings and TV menu.
 
Last edited:

Jay53

Active Member
I stood in the same place in D2 and get pretty much the same effect on Xbox series X using 55in q85r (I use game mode but did try the others too) so I don't think it's just your TV :thumbsup:
 

mmj

Active Member
This may be relevant:

He talks about the HGIG tone mapping.

If other HDR games are okay then it's more likely to be something with the game settings.
 
Last edited:

Barrowulf

Novice Member
Yeah, Jay53; those bright skies, radiolarian lakes, and even casting your super just crushes things around them in darkness and makes it more difficult to see. 😆

Thanks again, mmj, that video was enlightening (and became a new subscriber to them). I remember reading that the TV's HGiG isn't disabling all tone mapping, which I believe it's supposed to. And I've definitely experienced what he was showing when adjusting the sliders in Destiny 2; they luminance reacts and adjusts itself while trying to calibrate it. I'll also try making the adjustments faster within the HDR calibration tool so that the TV doesn't react to it and make its own adjustments that mess with the final result.

So, the HDR calibration tool on the Xbox mainly pertains to HGiG? Will it have an effect on games with HGiG disabled on the TV? I'll have to try disabling it and reconfiguring things.
 

mmj

Active Member
I'm by no means an expert just going by what I've read but HGIG was supposed to be an agreed upon standard that everyone adhered to for a more consistent HDR experience, Samsung not actually adhering to the specification kind of defies the whole point in it.

I don't have an Xbox so don't know. Try following this:
 

Barrowulf

Novice Member
Thanks again, appreciate the help! Vincent is great, will watch these and tinker with things further when I get a chance.
 

Barrowulf

Novice Member
Also, I've compiled a list of my current settings:

Current Software Version: 1460

[Picture]

Picture Mode: Game
Brightness: 50
Contrast: 50
Sharpness: 0
Color: 30 (gave it a small +5 bump)
Tint: 0
Picture Clarity Settings: Disabled
Local Dimming: Standard
Contrast Enhancer: Low
Color Tone: Warm1
White Balance: Default Settings
Gamma: ST.2084 (switches to BT.1886 in SDR)
ST.2084: 0 (max is 3)
Shadow Detail: 2 (max is 5)
RGB Only Mode: Disabled
Color Space Settings: Auto

[General]

Intelligent Mode Settings: All settings off
Eco Solution: All settings off
Accessibility: All settings off
Smart Features: All settings off

[General>External Device Manager]

Anynet+(HDMI-CEC): On
Game Mode Settings:
Game Mode: On
Surround Sound: Off
Dynamic Black Equalizer: 0 (max is 5)
Game Motion Plus: Disabled
Input Signal Plus: On for HDMI1 and HDMI4
HDMI1: Roku
HDMI2: Empty
HDMI3 (eARC): Samsung Q70T Soundbar
HDMI4 (Game): Xbox Series X
HDMI Black Level: Auto (Auto and Low are the same; Normal makes the shadows a bit less crushed, but the overall picture looks hazy and washed out.)
HGiG: On

[Xbox Series X]

[TV and Display Options]

Resolution: 4K UHD
Refresh Rate: 120 Hz
Video Modes Allowed:
50 Hz: On
24 Hz: On
Auto Low Latency Mode: On
Variable Refresh Rate: On
YCC 4:2:2: Off
4K: On
HDR10: On
Auto HDR: On
Dolby Vision: Disabled
Video Fidelity & Overscan:
Color Depth: 30 bits per pixel (10-bit) (other is 24 bits per pixel (8-bit))
Color Space: Standard (other is PC RGB)

Calibrate HDR for Games:

I adjusted the slider for black so that I can barely see the pattern, like it said (should I instead make the pattern even more visible or less?). I adjusted the slider for white so that I no longer see the pattern, like it said. (I still have to try doing it faster so the TV isn't making adjustments and making the pattern visible again, messing up the results.)

Calibrate TV:

When I'm Calibrating the TV I can see everything fine, it's just the "closed eye" that I can't see unless I set HDMI Black Level to Normal (instead of Auto or Low). (Though, the instructions on the app say to set the Xbox to Standard, like I have, and Black Level to Auto/Low/Limited.) Also, when doing these calibrations, the Gamma switches to BT.1886.

xKppv8G.jpg

tkAkiFv.jpg


Also, I once entered into the service menu, but didn't change anything because the settings PWM_INI_2D and PWM_MOVIE_INI were already set to 100, which users were saying fixed some dimming issues. Perhaps Samsung changed those values in an update.

IJ6uzYv.jpg
 

mmj

Active Member
I suppose it must just be an artistic choice then, if you don't like it or it's affecting your play you're probably better off just turning off HDR.

Your settings look okay, contrast enhancer and shadow detail are probably messing with dark areas but if you prefer them on so be it. I'd keep out of the service menu though unless you know what you're doing, if you are going to change anything make a note of what the original settings were.
 

Jay53

Active Member
Also, I've compiled a list of my current settings:

[Xbox Series X]

[TV and Display Options]

Resolution: 4K UHD
Refresh Rate: 120 Hz
Video Modes Allowed:
50 Hz: On
24 Hz: On
Auto Low Latency Mode: On
Variable Refresh Rate: On
YCC 4:2:2: Off
4K: On
HDR10: On
Auto HDR: On
Dolby Vision: Disabled
Video Fidelity & Overscan:
Color Depth: 30 bits per pixel (10-bit) (other is 24 bits per pixel (8-bit))
Color Space: Standard (other is PC RGB)

I cant comment on the TV settings as my TV is a Q85R so doesn't have HGIG. Interestingly it doesn't suffer from the checkerboard reappearing as you try and calibrate on the Xbox series X. I can click slowly up to get to the point on the 10% luminance and 100% luminance screens where it goes all white and it stays all white. The other vid I think mentions rapidly clicking 14times from minimum to set it to 1000nits as this value gets used quite a bit and whilst the TV can go higher someone else mentioned in game mode it actually only teaches 700 so 14clicks is more than enough.

Anyway on the something else I noticed in your settings as it comes down to personal preference.

The colour depth on xbox only affects SDR which typically is mastered for 8bit colour depth. Setting it to 10bit doesn't really achieve much as with allow HDR set the Xbox will switch to 10bit on our tvs anyway regardless of what the colour depth is set to.

Also, the auto HDR again only applies to SDR and it attempts to remap SDR to HDR. Some people like this but all that's happening is the Xbox is tone mapping the SDR content into the HDR colour space and then the TV is tone mapping that to what it's capable of. Much better surely to just let the Xbox output SDR as is and let the TV sort out how to display the SDR content.
 

Barrowulf

Novice Member
So, after watching more of Vincent's HDTVTest channel, I think I now believe what's happening. Even with HGiG enabled, the TV is using dynamic tone mapping to make the details of bright areas more visible. It does this by dimming everything. So, the bright areas are getting dimmed so details aren't lost, but, by dimming everything, it also results in the darker areas getting crushed.

Anyway, I've calibrated HDR on the Xbox per Vincent's video. I set the black point all the way down to 0 nits and then bumped it up 10 clicks since I don't play in the dark often. Though, most importantly, I fixed the two white points. Previously, I had them way too high because I was following the instructions on screen to make the squares disappear. But, since the Q90T still uses dynamic tone mapping and adjusts the brightness to make things visible, it was messing up the calibration. So, for both whites, I turned them all the way down (which equals 300 nits) and then I clicked them up 14 times to set them at 1,000 nits (300 + 14 * 50 = 1,000).

It may just be in my head, but things like the bright skies in game looked a little better. Perhaps the dimming of the dark areas around them was lessened too, I don't know. I still wish they wouldn't dim at all, but Destiny just has a wide range of lighting and effects, showing both very dark and bright things on the screen at the same time. Even when comparing the preview images after calibrating on the Xbox, the calibrated one looked better than the uncalibrated version, so I guess it's doing something good.

I still wish there was some kind of option to disable dynamic tone mapping, or at the very least, leave things as is if HGiG is enabled, like it's supposed to do.
 

Barrowulf

Novice Member
That is just how HDR looks on Destiny 2
Yes, I'm just starting to accept that too.

I suppose it must just be an artistic choice then, if you don't like it or it's affecting your play you're probably better off just turning off HDR.

Your settings look okay, contrast enhancer and shadow detail are probably messing with dark areas but if you prefer them on so be it. I'd keep out of the service menu though unless you know what you're doing, if you are going to change anything make a note of what the original settings were.
I've tried the SDR version and it still dims a bit while also not looking as good. I'll just live with the occasional dimming in HDR.

Yeah, I'm very cautious with the service menu; I haven't touched anything and don't plan on tinkering with any of it, I'm just leaving it as is.

I cant comment on the TV settings as my TV is a Q85R so doesn't have HGIG. Interestingly it doesn't suffer from the checkerboard reappearing as you try and calibrate on the Xbox series X. I can click slowly up to get to the point on the 10% luminance and 100% luminance screens where it goes all white and it stays all white. The other vid I think mentions rapidly clicking 14times from minimum to set it to 1000nits as this value gets used quite a bit and whilst the TV can go higher someone else mentioned in game mode it actually only teaches 700 so 14clicks is more than enough.

Anyway on the something else I noticed in your settings as it comes down to personal preference.

The colour depth on xbox only affects SDR which typically is mastered for 8bit colour depth. Setting it to 10bit doesn't really achieve much as with allow HDR set the Xbox will switch to 10bit on our tvs anyway regardless of what the colour depth is set to.

Also, the auto HDR again only applies to SDR and it attempts to remap SDR to HDR. Some people like this but all that's happening is the Xbox is tone mapping the SDR content into the HDR colour space and then the TV is tone mapping that to what it's capable of. Much better surely to just let the Xbox output SDR as is and let the TV sort out how to display the SDR content.

Oh, that's interesting, I'll have to look into the max nits in game mode. Maybe I'll try setting them to 700 nits and seeing how that looks. So, that would be only 8 clicks up. I also should see how the game looks and performs in movie mode. I'm far from a sweaty competitor, so maybe the bump in latency isn't as bad.

Yeah, I saw those things mentioned in the videos as well, I set mine to 8 bit since it'll automatically go to 10 bit with HDR content anyway. I also disabled the Auto HDR so that SDR games are displayed as they were originally intended by their designers. Plus, I've heard that Auto HDR can even degrade an SDR game that wasn't intended for HDR.
 

Dibils

Active Member
So, after watching more of Vincent's HDTVTest channel, I think I now believe what's happening. Even with HGiG enabled, the TV is using dynamic tone mapping to make the details of bright areas more visible. It does this by dimming everything. So, the bright areas are getting dimmed so details aren't lost, but, by dimming everything, it also results in the darker areas getting crushed.

Anyway, I've calibrated HDR on the Xbox per Vincent's video. I set the black point all the way down to 0 nits and then bumped it up 10 clicks since I don't play in the dark often. Though, most importantly, I fixed the two white points. Previously, I had them way too high because I was following the instructions on screen to make the squares disappear. But, since the Q90T still uses dynamic tone mapping and adjusts the brightness to make things visible, it was messing up the calibration. So, for both whites, I turned them all the way down (which equals 300 nits) and then I clicked them up 14 times to set them at 1,000 nits (300 + 14 * 50 = 1,000).

It may just be in my head, but things like the bright skies in game looked a little better. Perhaps the dimming of the dark areas around them was lessened too, I don't know. I still wish they wouldn't dim at all, but Destiny just has a wide range of lighting and effects, showing both very dark and bright things on the screen at the same time. Even when comparing the preview images after calibrating on the Xbox, the calibrated one looked better than the uncalibrated version, so I guess it's doing something good.

I still wish there was some kind of option to disable dynamic tone mapping, or at the very least, leave things as is if HGiG is enabled, like it's supposed to do.
This is likely placebo, since the only game that uses HGIG on xbox currently is Dirt 5 and COD:Cold War

other games, you need to change the in-game HDR settings
 

MrDanteZ

Member
Also, I've compiled a list of my current settings:

Current Software Version: 1460

[Picture]

Picture Mode: Game
Brightness: 50
Contrast: 50
Sharpness: 0
Color: 30 (gave it a small +5 bump)
Tint: 0
Picture Clarity Settings: Disabled
Local Dimming: Standard
Contrast Enhancer: Low
Color Tone: Warm1
White Balance: Default Settings
Gamma: ST.2084 (switches to BT.1886 in SDR)
ST.2084: 0 (max is 3)
Shadow Detail: 2 (max is 5)
RGB Only Mode: Disabled
Color Space Settings: Auto

[General]

Intelligent Mode Settings: All settings off
Eco Solution: All settings off
Accessibility: All settings off
Smart Features: All settings off

[General>External Device Manager]

Anynet+(HDMI-CEC): On
Game Mode Settings:
Game Mode: On
Surround Sound: Off
Dynamic Black Equalizer: 0 (max is 5)
Game Motion Plus: Disabled
Input Signal Plus: On for HDMI1 and HDMI4
HDMI1: Roku
HDMI2: Empty
HDMI3 (eARC): Samsung Q70T Soundbar
HDMI4 (Game): Xbox Series X
HDMI Black Level: Auto (Auto and Low are the same; Normal makes the shadows a bit less crushed, but the overall picture looks hazy and washed out.)
HGiG: On

[Xbox Series X]

[TV and Display Options]

Resolution: 4K UHD
Refresh Rate: 120 Hz
Video Modes Allowed:
50 Hz: On
24 Hz: On
Auto Low Latency Mode: On
Variable Refresh Rate: On
YCC 4:2:2: Off
4K: On
HDR10: On
Auto HDR: On
Dolby Vision: Disabled
Video Fidelity & Overscan:
Color Depth: 30 bits per pixel (10-bit) (other is 24 bits per pixel (8-bit))
Color Space: Standard (other is PC RGB)

Calibrate HDR for Games:

I adjusted the slider for black so that I can barely see the pattern, like it said (should I instead make the pattern even more visible or less?). I adjusted the slider for white so that I no longer see the pattern, like it said. (I still have to try doing it faster so the TV isn't making adjustments and making the pattern visible again, messing up the results.)

Calibrate TV:

When I'm Calibrating the TV I can see everything fine, it's just the "closed eye" that I can't see unless I set HDMI Black Level to Normal (instead of Auto or Low). (Though, the instructions on the app say to set the Xbox to Standard, like I have, and Black Level to Auto/Low/Limited.) Also, when doing these calibrations, the Gamma switches to BT.1886.

xKppv8G.jpg

tkAkiFv.jpg


Also, I once entered into the service menu, but didn't change anything because the settings PWM_INI_2D and PWM_MOVIE_INI were already set to 100, which users were saying fixed some dimming issues. Perhaps Samsung changed those values in an update.

IJ6uzYv.jpg
How did you unlock the PWM settings in Q90T?
 

Barrowulf

Novice Member
How did you unlock the PWM settings in Q90T?

Now, instead of pressing 0000 to reveal the hidden menu items under "Advanced", try holding the volume+ button for 5 or more seconds.

You may already be aware, but be careful with changing settings in there, you could damage your TV.
 

Barrowulf

Novice Member
Try to set default position for black and white point in game menu
Yeah, I have those set to their default values on the slider within Destiny 2. Those settings seem to work best. Also, when disabling HDR, Destiny 2's brightness setting is also at its default value of 4; since users say the HDR settings also use that setting as a base.

I'm just accepting that Destiny 2 just has a unique art style, with very bright areas and very dark areas that contrast them.

If only I could figure out how to lessen the dimming when viewing bright areas/objects, it would be perfect. For now, I just live with it. I don't really notice it too much in other games. In a game like Doom Eternal it's barely noticeable. But, in others, like Immortals Fenyx Rising, it's very noticeable in certain situations, like facing an exit to outside daylight while inside of a cave, everything around the opening gets very dark.

Like I said above, I think this is done because the brightness is perhaps too bright and the screen is trying to make it more visible by dimming the entire screen -- it's just more noticeable around the darker areas when they go black.

I guess if it didn't do this, I would have the opposite effect: the brightness would maybe be blinding and I wouldn't be able to make things out in it, while the darker areas of the screen would remain the same.

So, probably the best solution would be to lessen the dimming effect instead of completely disabling it.
 

PhoxM

Novice Member
I saw D2 PC gameplay on youtube and it goes with the same dark zones troubles. It's normal for D2, not easy properly adjust D2 HDR. But my Q90T works better with D2 HDR, than the previous Q80R. I'm play on XSX and like D2. Unfortunately, D2 devs ignor this hdr bug.
 

Shotgun Mick

Active Member
I have had the Q95T for a couple of months and I have noticed the screen dimming when playing on warzone on the ps4. The best way I can describe it is that it's similar to when a phone screen adjusts to the light when you're using it.

Basically on the darker screens (i.e warzone map) the q95t screen noticeably adjusts and dims but then brightens again when more is happening on the screen.

Is this the same issue you are discussing on here? I'm sure it didn't used to do it and has only started since I started adjusting the picture settings but I have tried everything to stop it.

Like I say, it's a similar feel to when you go indoors with your phone and the screen adjusts and dims down. Any ideas?
 

The latest video from AVForums

Podcast: Hisense A7G, Zidoo Z1000 & Kudos Cardea C10 Reviews + Movie News and Reviews
Subscribe to our YouTube channel

Latest News

Amazon Prime Day 2021 coming 21st -22nd June
  • By Andy Bassett
  • Published
What's new on UK streaming services for July 2021
  • By Andy Bassett
  • Published
Samsung launches Odyssey G9 gaming monitor
  • By Andy Bassett
  • Published
BenQ launches V7000i/V7050i 4K laser TV projector
  • By Andy Bassett
  • Published
Bang & Olufsen introduces 55-inch Beovision Contour OLED TV
  • By Andy Bassett
  • Published
Support AVForums with Patreon

Top Bottom