PUS8505 - cannot pair remote


Novice Member
Guys, pls need urgent help.
I've sold my TV 8505, which was stored last week perfectly working in original box. I took out the batteries in my TV remote.
Today buyer came to take the TV, we started it to check everything, and remote started to go crazy. it ask me all the time to pair the remote, which was already done.
I paired again the remote with TV, it stored the pair settings, at least TV says that, and on first press on any button it asks me to pair again. And so on in the circle.
I factory reseted TV, even tried other TV remote from my OLED Phillips, which is the same, and the very same thing is happening.
TV have latest updates, all worked till few days ago. It's even recognized in settings.


  • 20211206_194249.jpg
    153.7 KB · Views: 23
  • 20211206_194353.jpg
    231 KB · Views: 25
  • 20211206_194636.jpg
    129 KB · Views: 24
Last edited:


Novice Member
I'm so dumb. There is a button at the bottom of the TV, and of course it was pressed when TV laying on the floor without stand lol 😂
Last edited:

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom