1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSW2000 Help before wife gets in!!!

Discussion in 'Subwoofers' started by Anastie, May 27, 2005.

  1. Anastie

    Anastie
    Active Member

    Joined:
    Jul 15, 2003
    Messages:
    1,848
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    UK
    Ratings:
    +192
    Hi all I have just bought an immaculate Kef PSW2000 of Ebay. However I cannot hear any bass from it. I have a single phono going from my Pioneer VSX912 as I had before to my previous subs input phono. I have tried it in each of the input and output phonos on the PSW2000. I can feel the subs speaker move but I hear no thundery base. I have turned each control setting on the sub all the way up, down and midpoint. No difference :rolleyes:

    Im sure Im doing something very simple wrong. But need to know before wife gets in from work as she took some persuading to agree to me buying this :eek:
     
  2. hornydragon

    hornydragon
    Well-known Member

    Joined:
    Dec 19, 2001
    Messages:
    28,293
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Somewhere near the M4 most of the time......
    Ratings:
    +1,215
    does the LED come on?
     
  3. Anastie

    Anastie
    Active Member

    Joined:
    Jul 15, 2003
    Messages:
    1,848
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    UK
    Ratings:
    +192
    Led comes on .I can feel the sub moving when playing a movie but i got no bass. Wondered if I had it connected wrong to sub
     
  4. hornydragon

    hornydragon
    Well-known Member

    Joined:
    Dec 19, 2001
    Messages:
    28,293
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Somewhere near the M4 most of the time......
    Ratings:
    +1,215
    I dont have a huge amount of experience with the SUB but have you tried the manual may be on kef website
     
  5. Garfield

    Garfield
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Sounds like the phase is wrong ... 180 degrees about so when it should push it does the opposite so it cancels out what ever the other speakers do ....

    Look for a phase switch .....
     
  6. Andywilliams

    Andywilliams
    Active Member

    Joined:
    Sep 27, 2002
    Messages:
    2,077
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    notts.
    Ratings:
    +63
    Hi
    Check your amp speaker settings, Speakers small sub on.
    Cheers Gonzo.
     

Share This Page

Loading...