PS51D6900 + [email protected] in "DVI PC" mode = blue overlay

noikz

Member
I've posted this within the PS51D6900 and PS59D6900 threads already but I thought it may get lost in those threads.

I've now tested this on 3 different sets with identical results each time with Samsung spouting the same "get a replacement from your retailer" reply. It obviously needs a fix via a firmware update, I've seen the same fault with both v1007 and the most current 1009 updates.

If you connect a PC (outputting [email protected]) to HDMI1/DVI and label it as either "DVI PC" or "PC", the TV will intermittently apply a blue overlay to the display. I've tried it with a PS3 also just to check it's not the 3 different PCs that I've used, and the PS3 was the same. It never does it if the input is labelled as something else (BluRay, Satellite etc), but then that doesn't enable "PC mode" with smooth text and no over scan etc.

To reproduce:

Attach a PC via HDMI 1/DVI
Label the source as PC or DVI PC
Select a source on HDMI 2, 3 or 4
Turn off TV
Turn TV on (TV should be on the HDMI source you selected before powering off)
Switch to HDMI1/DVI (a blue tint should now be covering the entire screen)
Cycle the power again to get rid of it


 
Last edited:

JMach

Standard Member
OMG I'm so glad I found this, I've been having this exact same problem. My old Sony worked perfectly with my media PC but with my new PS51D6900 I keep getting this blue problem also.

Samsung keep offering to replace the television but I've already had it replaced once from John Lewis.

I'm on v1007 firmware.
 

StumpyBloke

Well-known Member
I can also confirm that on my 2 sets (51D6900) this problem exists!

Rich
 

ArmitageShanks

Well-known Member
Does it happen if the PC is connected to any of the other HDMI ports, or only HDMI1? Is there no way to switch off overscan on non-PC sources?

Got one of these sets on order which I plan to use with an HTPC. Don't think it'll be a huge problem for me yet, since the HTPC will be my only HDMI input.
 

noikz

Member
Does it happen if the PC is connected to any of the other HDMI ports, or only HDMI1? Is there no way to switch off overscan on non-PC sources?

Got one of these sets on order which I plan to use with an HTPC. Don't think it'll be a huge problem for me yet, since the HTPC will be my only HDMI input.
It doesn't happen on the other HDMI inputs as they don't support a DVI PC input properly.

When the TV is in "PC mode" it disables the option for "Just Scan" as it's not needed (colour adjustment is also not needed). When you use "Just Scan" on another HDMI input or the HDMI1/DVI input with the label set to something other than "DVI PC" you can tell that the image is not being displayed correctly (no 1:1 pixel mapping) as the image displayed is not perfect (jaggy fonts etc).

It's incredibly annoying, especially as you can't get through to a proper technical engineer at Samsung, only the drones on customer service and their step 1-2-3 scripts.
 

greg_SA

Novice Member
That is a real pity :(

Anyone know if this also applies to the 51D550?
 

ArmitageShanks

Well-known Member
When the TV is in "PC mode" it disables the option for "Just Scan" as it's not needed (colour adjustment is also not needed). When you use "Just Scan" on another HDMI input or the HDMI1/DVI input with the label set to something other than "DVI PC" you can tell that the image is not being displayed correctly (no 1:1 pixel mapping) as the image displayed is not perfect (jaggy fonts etc).
I thought Samsung displays had some "Screen Fit" picture sizing option that gives you the 1:1 pixel mapping rather than overscanning? Did they remove it?

Edit: Just checked the online manual on the Samsung website - it should be there under Picture -> Screen Adjustment -> Picture Size:

"Screen Fit: Displays the full image without any cut-off when HDMI (720p / 1080i / 1080p) or Component (1080i / 1080p) signals are inputted."

Don't know if that helps. Looking at the manual, it says the option isn't available for PC sources (presumably if you've labeled it as "PC"), but it should be available otherwise. Guess I'll find out when I get mine! :p
 
Last edited:

noikz

Member
I thought Samsung displays had some "Screen Fit" picture sizing option that gives you the 1:1 pixel mapping rather than overscanning? Did they remove it?

Edit: Just checked the online manual on the Samsung website - it should be there under Picture -> Screen Adjustment -> Picture Size:

"Screen Fit: Displays the full image without any cut-off when HDMI (720p / 1080i / 1080p) or Component (1080i / 1080p) signals are inputted."

Don't know if that helps. Looking at the manual, it says the option isn't available for PC sources (presumably if you've labeled it as "PC"), but it should be available otherwise. Guess I'll find out when I get mine! :p
Yeah if you label it as "Blu-ray/Satellite" etc you can choose "Just Scan" but you'll notice the PQ is not right. Fonts within XBMC's UI for example have jagged edges. "Without any cut off" just means the TV squishes the picture down to fit.

At [email protected] it looks great (when it's in PC mode), if you drop the refresh rate the TV drops back out of PC mode again and the regular TV options for Just Scan and Colour are available again (which they shouldn't be).

The blue overlay is not there all the time, I'm putting up with it by switching the TV to standby and back on again whenever I need to get rid of it. It happens if you power the TV up on another HDMI source and then switch back to HDMI1/DVI. If the TV is powered up whilst already on HDMI1/DVI, the blue overlay does not appear.
 

ArmitageShanks

Well-known Member
Hmmm, I'll have to see how much that is going to bother me since I only have the one HDMI source at the moment which I'll hopefully be using for everthing. Is there any way to log this sort of bug with Samsung? Perhaps with their Korean support if the UK support is rubbish?

Still can't wait to get my hands on this TV. Next Friday can't come soon enough!
 

noikz

Member
Hmmm, I'll have to see how much that is going to bother me since I only have the one HDMI source at the moment which I'll hopefully be using for everthing. Is there any way to log this sort of bug with Samsung? Perhaps with their Korean support if the UK support is rubbish?

Still can't wait to get my hands on this TV. Next Friday can't come soon enough!
Let me know how it goes, fingers crossed it's only affecting a certain batch of the sets. If you're only using the Media PC you should be fine anyway as it only happens when you fire the TV up whilst on another of the HDMI inputs. :thumbsup:

I've spoken to the default "technical support" for the UK, which is actually based in Cairo, they were useless. I managed to talk to a manager in the UK customer service department, which is actually in the UK. He said he was going to pass the details on to "someone" but I'm not banking on anything.

I'm hoping for a firmware fix within my 28 day after delivery window, if not I'll get it swapped again. :suicide:
 

noikz

Member
After having this problem on several PS51D6900s and a PS59D6900 and using a bit of a trial and error testing. I've found that setting "Digital Noise Filter" to "Off" on HDMI 2, 3 or 4 will cause the blue tint/lack of red on HDMI1/DVI under the conditions stated further up.

If you set "Digital Noise Filter" to anything else (I've set mine to "Low") on HDMI 2, 3 or 4 you will never see this problem in PC mode.

Hopefully Samsung will fix it at some stage within a firmware update, but for now I'm at least happy that I can get rid of it.
 

The latest video from AVForums

Podcast: Philips OLED+935 impressions, Denon AVC110 Review, Film Reviews, News and More...
Top Bottom