• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question PS4 ARC not auto switching with Sony HTXT1 Soundbase

gingerjedi

Active Member
Hi,

I have a Sony HTXT1 soundbase coupled to a Sony KDL43W755 which all works flawlessly apart from a switching issue which I assume should be automatic? If I'm watching a free to air digital channel and power on my Sky box the ARC function switches to Sky automatically but this doesn't happen with the PS4? I have to manually press the source button on the soundbase remote. Is there something I have to turn on somewhere in the PS4 settings?

Also does anyone know how to switch between sources using the TV remote? If I bring up the input select I get all the TV HDMI ports listed but everything goes through the soundbase so I have to use that remote to switch, sure I should be able to do this on the TV remote?
 

qfk123

Active Member
Hi, I had a XT1 plugged into a 2014 Panasonic LCD TV - xt1 on TVs arc port and Sky HD on input 1 and ps4 on input 2.

When I switched on the ps4 the xt1 would auto switch to that input and when switched off would go back to the sky input.

Make sure the hdmi link feature on the ps4 is switched on , make sure Bravia sync is enabled on TV and also on the XT1 the arc or hdmi link is set to on.
 

gingerjedi

Active Member
Make sure the hdmi link feature on the ps4 is switched on , make sure Bravia sync is enabled on TV and also on the XT1 the arc or hdmi link is set to on.

Thanks for that, I didn't realise there was a setting on the PS4 as the Sky box just worked.
 

qfk123

Active Member
Hopefully that sorts it , you should be able to navigate the ps4 using your TV remote as well being a Sony .
 

gingerjedi

Active Member
Yes all good, my sky box and PS4 both cause the TV to automatically switch to the correct input.

Should the Xbox 360 do the same? At the moment it just sits in a pre-boot state waiting for the HDMI 'handshake' and doesn't boot until I manually switch inputs. I've looked through all the settings so I guess it just doesn't support power control. I don't use it myself but my kids do so it would have been a 'nice to have' feature but not essential.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom