• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

PS3 wont read games but plays dvds

chezybezy

Active Member
this links with my other post; short version ive been given a fat PS3 no idea if it was working or not and only had just the barebones system.

still trying to figure out what to do with the controller but i picked up a cheapy game to test (haze 0.99p!) and it looks like the PS3 is having problems with the drive. luckily i didn't pick up my complied list of games i wanted :D

if anyone has any experience with ps3's id be grateful if you can give me a hand.

it seems fine with self burned dvds, and a ps2 demo disc is recognised (although obviously it it isnt playable), ive yet to try a bluray movie and a ps2 game. when i put in the ps3 game it takes ages to read it and show up on the dash as what it is also if i press triangle for more info about the game it takes a long time to eventually show the info such as age restriction type 9, the game name etc.

if i set it to auto load the game when put in it loads the Haze "logo" and then sits there. The first time i tried it got to the the installing game data screen (the one just after the haze logo but stuck at 0% - PS3 was vertical. i put the PS3 horizontal and now when i try it it seems to try read the disc, and produces an almost click sound every few seconds - this isnt random it is every 5 seconds. almost like the drive lifts the disc to read then tries to read it with the other lense (dvd / bluray) then realises it isnt able to read that one so tries to read it with the first one again - if that makes sense?

im thinking about ripping it apart and giving it a clean, isopropyl (isopropanol) 99.9% is the stuff i should be using on the lense right? and not rubbing alcohol. im assuming i cant use my articlean stuff i have for my CPU / heatsinks?

the funky thing is i got an error in one of my read attempts and when i googled it someone recommended i reinstall the BR software from the PS3 recovery console, but i need the official controller for that so atm i cant try that :(.

is there anything else i could try or any ideas anyone has?

update:
vertical - finally haze showed on the back picture of the menu system (handnt ever done so before) so i tried loading, it then reached the press start to play screen.
i tried several times and it seemed to not realise i was pressing anything however the normal over menu sound was playing so i thought it cant be frozen eventually (while i was looking for a bluray to test) it loaded the game video intro it got a little into it and then stopped (paused) and i could hear the disc noises (like the ones i mentioned before every x seconds) i left it a little while to see if it would eventually resume, it didnt.

tried 3 BRs non would load even in the PS3 menu - Red, Mr & Mrs Smith and Contact.

PS2 game i tried - Simpsons hit and run - loaded and i played it for a few mins seemed to be ok.

Tried the burned disc i had before and that loads.
 
Last edited:

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom