PS3 Phat - Can't hear movies

jazzdog74

Standard Member
Hi All

I'm trying to configure my PS3 Phat to work with my new Onlyo TX-NR808 receiver.

I can play audio cds and they play fine. However when I attempt to play a DVD or a BD disc, I get no sound whatsoever, apart from when the main menu appears.

The PS3 is connected to the amp via a HDMI cable.


My PS3 settings are as follows:
Audio Output Settings
Connector: HDMI
Output Format: Automatic (everything apart from AAC checked)
Video Settings
BD/DVD Audio Output Format: LPCM

Onkyo settings are pretty much out of the box.


Any help much appreciated.
JD :)
 

Broadz

Well-known Member
Are you exporting high definition audio that the Onkyo can't interpret?

Or do you need to set the Onkyo HDMI input to something other than PCM (which is almost certainly what the initial Blu Ray movies menu will be encoded in, but which most times will then be replaced by DD, DTS or high definition audio)?

Most AV amps/receivers allow you to set the input to Auto, which means it should detect any kind of audio input to it and be able to play it accordingly.
 

jazzdog74

Standard Member
Are you exporting high definition audio that the Onkyo can't interpret?

Or do you need to set the Onkyo HDMI input to something other than PCM (which is almost certainly what the initial Blu Ray movies menu will be encoded in, but which most times will then be replaced by DD, DTS or high definition audio)?

Most AV amps/receivers allow you to set the input to Auto, which means it should detect any kind of audio input to it and be able to play it accordingly.

Thanks for the reply.

I've managed to get some sound now when playing a DVD, but had to select 2.0 Dolby Surround rather than Dolby Digital 5.1 Surround in the DVD's sound options.

Still nothing BD soundtracks though.

I can't find the Auto option on the Onkyo. Nor do I know how to change the HDMI input to anything other than PCM on the amp.
 

Broadz

Well-known Member
I can't find the Auto option on the Onkyo. Nor do I know how to change the HDMI input to anything other than PCM on the amp.
So it is the amp which has not been set up to interpret DD5.1/DTS/HD audio properly. Don't you have an instruction manual that came with it?
 

jazzdog74

Standard Member
So it is the amp which has not been set up to interpret DD5.1/DTS/HD audio properly. Don't you have an instruction manual that came with it?
Mysteriously it has now started working!!

It now seems to be playing both BD and DVD soundtracks fine.

Yes I do have a manual, and I read it cover to cover umpteen times but couldn't find anything regarding changing the HDMI input to something other than PCM.

Thanks anyway.
 

Trending threads

Top Bottom