PS3 & Onkyo 606 - Divx 5.1 problem

gromit60

Standard Member
I have my PS3 connected to an Onkyo 606 by HDMI. When I play a Divx file that is encoded with 5.1 AC3 audio, I cannot get surround sound from the Onkyo regardless of whether I set the PS3 to PCM or Bitstream. Pressing Display on the PS3 confirms it's 5.1 Dolby Digital audio but the Onkyo just thinks it's plain stereo (or mono).

Can anyone shed any light on this? Is it that the PS3 doesn't handle AC3 correctly?
 

kingfats

Distinguished Member
I have my PS3 connected to an Onkyo 606 by HDMI. When I play a Divx file that is encoded with 5.1 AC3 audio, I cannot get surround sound from the Onkyo regardless of whether I set the PS3 to PCM or Bitstream. Pressing Display on the PS3 confirms it's 5.1 Dolby Digital audio but the Onkyo just thinks it's plain stereo (or mono).

Can anyone shed any light on this? Is it that the PS3 doesn't handle AC3 correctly?
Hi mate. :)
It wouldn't hurt posting and asking here as well. :smashin:
All the best.
 

Rob100

Novice Member
I have my PS3 connected to an Onkyo 606 by HDMI. When I play a Divx file that is encoded with 5.1 AC3 audio, I cannot get surround sound from the Onkyo regardless of whether I set the PS3 to PCM or Bitstream. Pressing Display on the PS3 confirms it's 5.1 Dolby Digital audio but the Onkyo just thinks it's plain stereo (or mono).

Can anyone shed any light on this? Is it that the PS3 doesn't handle AC3 correctly?
Not sure if the PS3 handles AVI's with AC3 audio correctly or not. Certainly handles .TS, .M2TS etc with AC3 5.1 audio correctly.

Do you get 5.1 from DVD and Blu-ray?

Have you tried using optical (bitstream)?
 

gromit60

Standard Member
Thanks, kingfats.

I've posted this in the Onkyo 606 Owners forum as suggested and have slightly changed it - just noticed it was an Xvid file, not Divx - not sure if that matters.
 

The latest video from AVForums

Podcast: Panasonic HX800 TV + Sony HT-G700 Soundbar reviews, movie and TV show news and reviews
Top Bottom