PS3 and Joytech 540C - incompatible?

Z

Zedd

Guest
Is anyone else having problems running their PS3 through a Joytech 540C control centre?

RFOM, Motorstorm and Tiger Woods work pretty much OK (just the odd 'No signal' message on the screen when the game switches between menus and gameplay), but Virtua tennis is completely invisible.

I know of one other forum member who is experiencing identical problems, but when speaking to Joytech they say their PS3 works fine and that I should "take it back to the shop"... like, who buys their kit from "Shops" nowadays!

If your 540C works, or it doesn't, I'd like to know as it will help me decide upon my next course of action.

Alternatively if you're using a device that successfully allows multiple Component inputs through a single output (with a PS3 and 360) I'd be very interested.

Many thanks
 
P

Paper Sword

Guest
I'm having similar problems. I seem to get an "out of range" message every now and again, but it only seems to happen if the image on screen is very bright, for example, if i go to the online user manual.

I can't decide what to do either. I bought mine from Dabs, so I'm going to start with an email to them.
 
P

Paper Sword

Guest
Just spoken to the Joytech Helpline and they've told me to send it back, so wait and see what the next one is like.
 
Z

Zedd

Guest
Are you sending it back to Joytech or Dabs?

Cheers

(Mine was from Dabs too)
 

RMGEE

Well-known Member
Sent mine back to Joytech yesterday but they say to allow 28 days for a replacment / refund, Only 27 days left to go :)

I have been looking at this http://www.jvcgate.co.uk/ to replace the 540c and my old surround DVD player but the cheapest I've found so far is £224.00, I think I'll wait until there's more info and reviews on it.

Rich.
 
P

Paper Sword

Guest
Received an email from Dabs - refund approved!:thumbsup: I don't know if I'm going to bother with another switcher now, easier to buy a new panel!!!
 

RMGEE

Well-known Member
Spoke to Joytech yesterday, they have tested my unit and found it to be faulty.

They have tested a new one that works with the PS3 and Wii and it should be with me in a few days.

I must say Joytech's technical support is poor, they don't communicate with you, when you phone the technical support they haven't got a clue, they don't even refund your postage, I wish that I just sent mine back to Amazon now for a refund.

Rich.
 

RMGEE

Well-known Member
Received my new 540c yesterday from Joytech and guess what ?

Its exactly the same, plugged the PS3 in and tried VT3 and the screen started to go all scrambled.

Phoned Joytech and was told that someone will get back to me in 24 hours.

Rich.
 
P

Paper Sword

Guest
I'd give up if I were you bud, I just don't think the kit is up to the job. Whether it's something to do with freqency range or just the basic quality of the components, who knows!
 

RMGEE

Well-known Member
Just got off the phone with Joytech, they now say that they have fixed the problem with an adaptor which fits onto the green component output.

They are sending me one out to try so fingers crossed :)

Rich.
 

RMGEE

Well-known Member
Finally received the adaptor and all I can say is if anyone has got a 540c return it now for a refund if you can.

It made everything dull (like using the 360 input if you have ever tried it) although it did fix the problem with the PS3 it has now caused more problems with the Wii with the signal dropping for a few seconds everytime you hit a load screen.

Joytech were completely hopeless and would not give me a refund, they asked me to return the 540c again at my own cost, I won't tell you my reply.

Just contacted amazon.co.uk who said to send it back and they will refund my card.

If anyone is thinking of buying one of these "PLEASE DON'T"

Rich.
 

lmaolmao

Active Member
i'm dragging this up because i own one of these, and if you get a bright white scene in your game your tv loses 'sync' you might want to give this a try.

today i had a 'fiddle' and if you plug the blue cables into the green sockets, and the green cables into the blue sockets, it works flawlessly. No stupid going blank on either my ps3 or my wii. i used a pure white jpeg to test (as previously it would lose sync when displaying that image fullscreen). also the level transitions on little big planet used to disappear, but now all is fine.

this may not work for others, and it may not be a brilliant fix as it stops you using the specific xbox cable. as i only use 480i/p on my consoles i dont know how it works with higher resolutions.

hope this is helpful.
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom